Jump to content

Unable to install mjpegtools, bad signatures


Recommended Posts

I have been trying to install mjpegtools-1.6.1-7mdk.i586.rpm on Mdk 10.1 Official. There are 3 other rpm's as pre-reqs. They are : libquicktime0-, libmjpegtools1.6-1.6.2-7mdk.i586.rpm, and libdirectfb0.9_20-2mdk.i586.rpm.


I have had urpmi set up for some time and not had problems installing other software. Most recently I installed mplayer without a problem.


Here is the error message I get.

There is a problem with the installation: retrieving failed, curl failed: exit with 7 or signal 0 unable to install package... ( it then lists the packages I'm trying to install.


I followed the link https://mandrivausers.org/index.php?showtopic=23154 . I have tried to no avail to make sure I have the correct keys installed. I'm not positive I did what is required. In particular the step



gpg --list-keys

> gpg --list-keys




pub 1024D/70771FF3 2002-03-13 Mandrake Linux <mandrake@mandrakesoft.com>

sub 1024g/75223F49 2002-03-13



The secibd line is confusing to me. Just what does "> gpg --list-keys' do? How do I verify I have done what is required? The last line is also confusing. If I go to /root/.gnupg and look at file pubring.gpg I can see information in this file. Once again, how dod I know it is correct?


Also, I have looked at /etc/urpmi/urpmi.cfg. I'm not sure how to verify I have the correct information in this file. Here is mine.


# generated Sat Sep 10 11:32:46 2005




contrib ftp://mirror.cs.wisc.edu/pub/mirrors/linu...official/10.1/i

586/media/contrib {

hdlist: hdlist.contrib.cz

key-ids: 78d019f5

with_hdlist: media_info/hdlist.cz



jpackage ftp://carroll.cac.psu.edu/pub/linux/distr...kelinux/officia

l/10.1/i586/media/jpackage {

hdlist: hdlist.jpackage.cz

key-ids: c431416d

with_hdlist: media_info/hdlist.cz



main ftp://ftp.lip6.fr/pub/linux/distributions...cial/10.1/i586/

media/main {

hdlist: hdlist.main.cz

key-ids: 70771ff3

with_hdlist: media_info/hdlist.cz



updates ftp://ftp.proxad.net/pub/Distributions_Li...x/official/upda

tes/10.1/main_updates {

hdlist: hdlist.updates.cz

key-ids: 22458a98

list: list.updates


with_hdlist: media_info/hdlist.cz



plf-nonfree ftp://ftp.free.fr/pub/Distributions_Linux...e/non-free/10.1 {

hdlist: hdlist.plf-nonfree.cz

key-ids: caba22ae

list: list.plf-nonfree

with_hdlist: hdlist.cz



plf-free ftp://ftp.free.fr/pub/Distributions_Linux...drake/free/10.1 {

hdlist: hdlist.plf-free.cz

key-ids: caba22ae

list: list.plf-free

with_hdlist: hdlist.cz



I'm concerned the last line of each entry, for example : with_hdlist: hdlist.cz is not as shown in article 23154. Should I add the ./ in front of hdlist.cz ???


Thanks in advance for any insight you provide.

Link to comment
Share on other sites

My experience is that whenever I got that Message, I needed to rerun easy-urpmi again after 2 or 3 hours because it meant that the mirror was not operating correctly and by delaying download attempts allowed the mirror to update correctly. When that didn't work, then selecting another mirror almost always solved the problem.

Save yourself some upset by remembering that Linux is not Windows and most of the time solutions are relatively simple, NOT complicated.


Cheers. John.

Link to comment
Share on other sites

AussieJohn, Thank-you for the response. I have managed to get mjpegtools installed. I downloaded the mdk.rpm and used urpmi to install it locally. The insteresting thing I don't understand is urpmi asked me if it was O.K. to get the pre-req's, ( I undestand the pre- req's) I said yes, and it downloaded them without a hitch, and every thing is now installed. Why this worked now and not before is what I don't get.... Purple smoke and mirrors I guess.


"Save yourself some upset by remembering that Linux is not Windows and most of the time solutions are relatively simple, NOT complicated." I appreciate your comment. I've been using linux for about three years now, and only work with windblows when one of the kids or the wifes machines is mucked up.


Urpmi has worked well for me. This is one of the few times Ihave had a problem with it. I was trying to follow the How_to on this forum to download and replace key files. Linux is a hobby for me. If something doesn't work, it is just a little challenge to learn something about.


Thank-you again for yoru help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...