Jump to content

Compilation Problems [solved]

Recommended Posts

Excuse me everyone, I'm trying to compile and install a software called "Tutka", perhaps you have heard of it. I originally used the autopackage file, but now I want to use a slightly deprecated version because it would run much better on my system. The autopackage runs very slow because it uses Pango and won't save/load (due to gnomeui I think). The rpm in urpmi has a version that doesn't use an ALSA MIDI port so working with my softsynth would be impossible. Anyhow, that's just some information on why I'm trying to compile Tutka version 12.0 instead of using any of the previous methods.

I swear I have all of the development libraries required to compile this. However, when I run ./configure, it tells me the following

checking for alsa >= 0.9 gtk+-2.0 >= 2.4 libgnomeui-2.0 >= 2.6 libxml-2.0 >= 2.4.16 libglade-2.0 >= 2.4... Package libglade-2.0 was not found in the pkg-config search path.

Perhaps you should add the directory containing `libglade-2.0.pc'

to the PKG_CONFIG_PATH environment variable

No package 'libglade-2.0' found


configure: error: Library requirements (alsa >= 0.9 gtk+-2.0 >= 2.4 libgnomeui-2.0 >= 2.6 libxml-2.0 >= 2.4.16 libglade-2.0 >= 2.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

I have all of the previous. I also have libgnomeui-2_0-devel installed, and I do have libglade and its development packages. Is there something I am missing? It suggests using pkg-config to configure my packages or something. How would I go by doing this? Any suggestions? I thank you in advance for even reading such an immense request :thanks: .


[moved from Software by spinynorman]

Edited by Lärs
Link to comment
Share on other sites

For me it sounds like this variable is not set. First, we need to find where libglade-2.0.pc is located. This is easy enough. First, su and supply root password, then type updatedb. This will update the slocate database. Then type slocate libglade-2.0.pc and it should report back where this is located.


Then we need to set the environment variable as mentioned above to point to the location of where libglade-2.0.pc is.


Hope this helps.

Link to comment
Share on other sites

Just to be sure, is libglade2.0_0-devel installed?

[rolf@localhost ~]$ urpmf  libglade-2.0.pc
[rolf@localhost ~]$ urpmq --sources libglade2.0_0-devel

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...