Jump to content
Sign in to follow this  
aze

[?] remove cd icon from gnome desktop

Recommended Posts

Hi all!

How do I remove cd/floopy icon from desktop?

I did that:

 

/home/user/.gnome-desktop/cdrom --> /home/user/.gnome-desktop/.cdrom

 

then I return to desktop and everything is fine (the icons has desapeared from there) but when I re-logon the annoying icons are back there.

 

How do I permanently remove those icons from gnome desktop?

Share this post


Link to post
Share on other sites

I was just hanging out on efnet in #mandrake and this very question came up. And my fiance dares ay I waste time on irc. HA I say. They went to cd to /home/user/.gnome-desktop and they swear they stayed deleted. Did you try it as root and delete them from your user desktop?Or is that my windows background showing up again?

Share this post


Link to post
Share on other sites

Really, doesn't matter what I do with the files at /home/user/.gnome-desktop in the next nogin gnome restore those annoying icons

Share this post


Link to post
Share on other sites

I ripped this right off of Dolsons site (http://icculus.org/~dolson/mdkxp/). He's talking about KDE but perhaps it's the same process for Gnome.

 

It's long so hold on tight.

 

There are two new features in Mandrake 9.0 that some users may really like a lot. I really hate them. So, I found a way to disable them. This tutorial will cover removing the Removable Media icon that reappears on your desktop every time you start KDE.

 

Open a console. Type in su and hit Enter.

 

Now you will be asked for the root password, so put it in and hit Enter.

 

Next, using your favorite editor (I'll assume Kate, as it's got a nice easy-to-use GUI about it) you must edit a config file. So, type in kate /usr/bin/kdesktop-links and hit Enter.

 

Go to line 17 or so, and you'll see something like this:

 

 

if [ ! -e $HOME/Desktop/.directory ]; then

cp -f /usr/share/mdk/kde/directory-desktop $HOME/Desktop/.directory

fi

 

# Removable media

 

 

If you see that, then great. You're editing the right file. Now, add in these lines that are in red:

 

 

if [ ! -e $HOME/Desktop/.directory ]; then

cp -f /usr/share/mdk/kde/directory-desktop $HOME/Desktop/.directory

fi

 

# Set MDKXP_DISABLE_DYNAMIC:

#

# 0 - Enable Removable Media icon

# 1 - Disable Removable Media icon

 

MDKXP_DISABLE_DYNAMIC=1

 

if [ $MDKXP_DISABLE_DYNAMIC == 0 ]; then # START MDKXP IF STATEMENT

 

# Removable media

 

 

So as you can see, if you set that variable to zero (MDKXP_DISABLE_DYNAMIC=0), then you would have the Removable Media icon when you restart KDE. But if you set it to 1, then the icon won't reappear once you delete it.

 

We need to make one final edit.

 

Scroll down to about line 134 or so. You should see something like this:

 

 

fi

 

if [ ! -e $HOME/Desktop/.md5sumetcfstab ]; then

md5sum /etc/fstab > $HOME/Desktop/.md5sumetcfstab

 

 

Now, add in this extra line that is in red:

 

 

fi

 

fi # END MDKXP IF STATEMENT

 

if [ ! -e $HOME/Desktop/.md5sumetcfstab ]; then

md5sum /etc/fstab > $HOME/Desktop/.md5sumetcfstab

 

 

Save the file and exit.

 

Delete the Removable Media icon from the desktop.

 

Restart KDE, and that annoying Removable Media icon won't come back to life.

 

One thing to be noted is that the line numbers are as found in the KDE version included with Mandrake 9.0 by default. If you upgrade KDE, the line numbers may change, and the icons will come back. You will need to do this tutorial again if you install a newer KDE version, and you will have to find the proper lines yourself.

Share this post


Link to post
Share on other sites

it dodn't work with gnome :-(

I already googled it but nothing says how to remove permanently them!

And I bet that nobody is caring about this little bit problem. :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...