Jump to content

Upgrade from 10.0 to 2005LE [solved]


Recommended Posts

Edit: Changed title - see below for what happened


I'm seriously thinking about upgrading from 10.0 to 2005LE, since it has the new ALSA drivers, updated KDE, new versions of GIMP and Kino (which I've never quite been able to install), an update function that still works, and a bunch of other stuff.


However, I've heard various tales of woe from people doing upgrades, so I'm asking for a little advice first.


Is there anything I really need to know about the upgrade process? What can I expect to be preserved, and what will I have to reinstall? (I have a separate /home partition, BTW).


If/when I decide to go ahead, I'll keep a log and post my experience here when I'm done.


Thanks in advance...

Edited by sellis
Link to comment
Share on other sites

I upgraded 10.1 to LE2005 and it worked more or less OK, other than I couldn't get my Intel video card working properly.


But other than that, I was up and running. You might be better with a clean install than an upgrade, but the way to upgrade is as follows:


Remove your existing urpmi sources and set up ones pointing to 2005 instead. Set up all of them.


Once this has been done, from the CLI type:


urpmi --auto-select --auto


This will ensure everything you have installed is updated using the urpmi sources. This could take a little while depending on speed of your internet connection.


It's also best that once this has been done, to update your kernel to 2.6.11-6mdk, and download the source too if you feel you need it, or have a previous source installed.


Then you need to install udev, as devfsd is unsupported in newer kernels, which you will be running at present with 10.0. Reboot after installing udev, and then remove devfsd.


Once it boots OK, you can remove your old kernel and source.

Link to comment
Share on other sites

... the way to upgrade is as follows ... <snip>

Thanks very much for the info!


Given the ease of a clean installation, I was expecting something more along the lines of "Boot to the CD/DVD, choose the Upgrade option, and go and make a cup of tea". (Actually, the urpmi part of the process sounds almost as easy as this.)


I have 2005LE on the latest Linux Format cover DVD, so I'm thinking that it should be possible to just point the urpmi sources at the appropriate directories on the DVD, rather than relying on the internet, especially as the internet is the other side of ndiswrapper, which always seems to lose its settings when I upgrade anything.


As for the kernel - and apologies for being a complete dimwit here - I've never updated the kernel before. According to this link http://www.webmasterworld.com/forum40/1138.htm it's as simple as typing "urpmi kernel" and off it goes. Is it really as simple as that?


The devfsd -> udev migration sound like a possible source of problems too, given what it does. I have a series of USB devices installed, for example. Again, is this just as simple as disabling devfsd and installing udev, or do I have to migrate any config files, etc?


Well, it looks like I've certainly got a project for this weekend. Now all I have to do is convince the wife that the new lights for the hallway don't need to go up just yet...

Link to comment
Share on other sites

If you have on CD/DVD, then you can choose upgrade when you boot from the CD. You won't need to set urpmi sources.


I assumed you were wanting to upgrade over the internet, so apologies if I misled you!


It's not too bad switching from devfsd to udev. Just make sure udev is installed, and that you reboot and boot normally before removing devfsd.


You may have to change the LILO configuration so it says devfs=nomount as well. I think on mine it did it automatically.


With the kernel, you can install as you mentioned urpmi kernel-2.6.11-6mdk.


I usually install the kernel-source at the same time!

Edited by ianw1974
Link to comment
Share on other sites

Marvellous. Even easier, then.


Thanks once again for your help. I'll let you know how it goes.

Link to comment
Share on other sites

OK, that was easier than I expected, with one wrinkle. Here's a step-by-step...


Booted to the 2005LE DVD, pressed Enter to install.

Selected English (British) (is there any other kind?), and Unicode support from the localization screen.

Accepted license.

It automagically detected my existing 10.0 system, so I just selected "upgrade"

Chose a UK keyboard

...and away we go.


It took about 20 minutes to upgrade all the packages It kept all of the configuration options, as far as I can tell. I asked it not to install updates, because I (rightly) assumed problems with ndiswrapper, and reboot.


All is well for a while, I get to the graphical login, and click on my icon, enter my password, and wait. And wait... and wait. Eventually I figure it's not just migrating settings (or whatever) and Ctrl-Alt-Backspace back to the login menu and reboot, paying more attention to the messages this time.


Now, at this point I am glad I printed out this thread, because ian was right on the money.


In the boot messages, there were various messages about devfs (as in "devfs still active!" or something equally amazed-sounding).


A quick reboot into failsafe mode, and hasty editing of the /etc/lilo.conf file ensued, changing all the "devfs=mount" to "devfs=nomount" entries everywhere. Reboot.


Now, everything works (almost). I can log in, and to my surprise all my settings are alive and well, including Firefox bookmarks, GAIM login, etc. Except, of course, that as usual ndiswrapper has evaporated, so I'm alone in the world, isolated from the net.


Worse, the instructions I had used before no longer worked! The way you deal with ndiswrapper has changed since Mandrake 10.0, so I've been fighting it for the last 2 hours trying to get it to install. Of course, I can't google for the answer because I need the answer to get to google! Arggh!


Thankfully, the same Linux Format cover disk that had 2005LE on it also has ndiswrapper 1.1, and more usefully, the documentation.


Instead of mucking about with lots of stuff in modprobe.conf, obtaining hardware IDs, ndiswrapper seems to be in the kernel already for 2005LE. It also has a vastly simplified installation procedure and it was simply a case of typing "ndiswrapper -i /etc/ndiswrapper/bcmwl5.inf" and presto - I'm back on the net bending your ear... you lucky people :P


Now all I have to do is see if it survives a reboot... Edit: yes, it does.

Edited by sellis
Link to comment
Share on other sites

yep. We had ndiswrapper in the kernel in 10.1 as well (IIRC) but it didn't actually work terribly well for everyone so recompiling was a good bet. The one in 2005 is fine. (The one in _Cooker_, on the other hand, you don't want to get me started about).

Link to comment
Share on other sites

  • 3 weeks later...

My wonderful friend Google found this page/thread for me the day after I upgraded my Thinkpad 240x from 10.0 to 2005LE. I had some wierd problems which were all related to having devfs still running. Thanks to the help above I fixed my problems. For completeness, I should add that after changing the boot options there are a couple of polite tidy-ups to do:


# /sbin/chkconfig --del devfsd

# rpm -e devfsd





Link to comment
Share on other sites

  • 2 months later...
Guest theraven_000

Ok, I am planning on upgrading from 10.1 to LE2005, however I don't want to lose lots of my data and programs.


I installed most of them in the /usr/local directory. Will these files get erased when I do an upgrade? What about programs I installed through rpmdrake like xmms and gftp?


Also, when I use urpmi to update my kernel is there anything I need to set up before hand?


Thanks a bunch!


EDIT>>> Ok, I was able to upgrade quite successfully. However, now my sound doesn't work at all. I'm not sure where to start here, so any help is appreciated. I'll be looking around for the answer in the meantime...


EDIT>>>> Fixed with alsaconf. Problem solved!

Edited by theraven_000
Link to comment
Share on other sites

  • 7 months later...

What's your issues? Normally, I've found with my card, and Intel 82852/82855 that I have to use the drivers from Intel to get direct rendering/3D stuff working. Else it doesn't work.


You might be better starting your problem in a new post that relates to the problem on your video card.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...