Jump to content

ATI Radeon Performance


Recommended Posts

That's weird... Why nvidia? What does /var/log/Xorg.0.log or /var/log/XFree86.0.log say?


When you load exteranl agpgart, do you have UseInternalAGPGART "No" in xorg.conf or XF86Config-4?


Do you boot into console or into GUI? To make sure agpgart is loaded before X starts, try booting into console, then check that agpgart is loaded, then start X from CLI.

Link to comment
Share on other sites

I have a Gigabyte system board that has NVidia stuff on it. However, there isn't any video built into the board as such. You still have to have an AGP card. I bought a Gigabyte ATI Radeon 9250 R925 version.


I'm assuming that agpgart is reporting what's on the motherboard, but not what is in the AGP slot. Or maybe it is, and I need to use NVidia drivers?


UseInternalAGP is set to No, and I know it's running before I run startx. I checked before to make sure, and then ran, but still no joy with glxgears or OpenGL.

Edited by ianw1974
Link to comment
Share on other sites

Have tried using agpgart as well as without, and still seem to have problems trying to get direct rendering or fps anywhere over 280!


Any ideas?



Did you make sure you set this part up correctly? If you don't do this with the ATI drivers they do tend to run slower than they should.





The display driver requires POSIX Shared Memory to be enabled on the system in order to run these applications correctly. This feature should be enabled by default on most current Linux distributions, but may be disabled intentionally by some system administrators or not included in older distributions.


To enable POSIX Shared Memory on your system, perform the following as root:


1. Add the following line to /etc/fstab (if it isn't there already): tmpfs /dev/shm tmpfs defaults 0 0

2. Mount shared memory as follows: mount /dev/shm

3. Issue the following command to check that it mounted properly: mount | grep "shm"


If the mount was successful, then the following output (or similar) should appear:

tmpfs on /dev/shm type tmpfs (rw)


At this point, POSIX Shared Memory is enabled. Your 3D applications should run properly and the error message above should no longer occur.


If the output from this command is blank, then the mount failed.


If /dev/shm fails to mount, then this feature may not be turned on in your Linux kernel. In this case we recommend upgrading to a more recent Linux kernel, or contacting your Linux Distribution vendor for more information on enabling POSIX Shared Memory.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...