Jump to content

I haven't a clue


Recommended Posts

I'm trying out the Live CD called Mandrake Move and I'm pretty much lost with it. I did post one question but I can't remember if I posted it on this site or somewhere else. Anyway at the desktop there are no icons for my external USB hard drive or my Zip drive, or one of my two optical drives. I have both a CD-ROM drive and a DVD-RW drive. It appears that Mandrake is calling my DVD drive hdc(cd-rom). The one fellow who answered my post said that the distro may not mount these drives automatically. He said that I could mount them manually by creating a directory for it to mount to. He went on to say this:



(sub in the actual username for the *username* above)



Anyway I don't know how to create a directory. I know how to open a terminal window and I know how to log in as root but that's about all. And if I do create a directory for my zip drive, then would I follow the same process for my USB external drive too? And if I do create these directories will that place icons on my desktop for each drive? I'm just a beginner so I just don't know how to do this stuff, but my first concern is to (if possible) have an icon on the desktop representing each drive on my computer and to be able to access each drive and look at it's contents. That seems like the first natural thing to do.

Link to comment
Share on other sites

Just a suggestion. Your first concern should be to know whether you can access your external drives. Then you can worry about making desktop icons to get to them.


Basically, a major difference between Windows and Linux is how you access a new storage system such as a hard drive or a USB drive. In Windows, this will create a new DRIVE letter. E.g. D: or E: (whatever). Each exists independantly of the other. You can open explorer and type




and go the file listing of the device. Think of this as a bunch of trees (with paths) sitting next to each other.


In linux, the archetecture is a little different. There is just one tree starting with slash / (notice that the slash goes the other way?).


/mnt/somefoldername/somefoldername (for example)


If you attach a new storage device, you need to indicate where in the current tree you want to attach it and then go to that location.




make a directory called /mnt/usb or /mnt/zipdrive (whatever you want to call it).


mount (means attach to the existing tree), your storage device to the tree. You indicate the folder you made and it will invisibilly attach it starting at that location. Now you can simply refer to that folder and you don't even care whether its a zip or a usb drive, cddrimve or just a plain old hard drive. That's one feature of linux I like.


So, to make a folder, you need to decide where you want it to be mounted into the directory tree. It's up to you. A good convention is to put it under /mnt. This folder should already exist for you since Mandrake uses it.


Try these steps. Type commands exactly for upper/lowercase.


1. Open the command window.

2. Change your location on the tree to the /mnt directory


cd /mnt


3. List the current contents of the folder.


ls (or try ls -1A)


4. If you see a folder called zipdrive, you don't need to make it. Otherwise, try making it.


mkdir /mnt/zipdrive

ls /mnt <- double check that the folder now exists


5. Now tell linux to mount the device at this location Below, /dev/sda1 is the hardware name of the zipdrive (to use windows terminology). Linux will know which device you are referring to based on this. The USB drive will have a different name, you will need to find out what it is. -t auto means to figure out automatically what kind of file system the drive has. FAT32? NTFS? so on..


mount -t auto /dev/sda1 /mnt/zipdrive


Look at any messages that appear. If you get an error then either you typed it wrong or you may have provided the wrong information (e.g. the device is not /dev/sda1.





Note that eventually you will not need to do this everytime. But this time, learn the concepts so you can make it automatic later.


6. Now see if you can access your drive. You can do this in the command line with the ls command


ls /mnt/zipdrive


or try doing it at the desktop level


let us know how you make out..

Link to comment
Share on other sites

Well first someone on PCMag's Linux forum told me I can open a console window and type in cat /etc/fstab and it will show a list of all detected and mountable storage present on my system. Well I did that and it showed this:


/dev/hdc/ /cdrom

/dev/hdd/ mnt/cdrom2

/dev/hda1 /mnt/win _c ntfs

/dev/hda5 /mnt/win_d ntfs


That's all it showed(it listed a bunch of other crytic stuff after each device but I didn't write that down.)


So it appears that Mandrake is detecting both my optical drives and my two Windows partitions on my hard drive. It does not list my external USB hard drive or my Zip drive. So does that mean that I can't use Mandrake on my system or can I still go through the steps you outlined and add these drives?

Link to comment
Share on other sites

The /etc/fstab file is where you can permanently add info on how to automatically attach and mount hardware storage devices. This is why you don't have to build your normal operating tree each time you start linux up. There is a step that processes the fstab file.


In your case, you should try the steps I outlined to determine whether this will work at all. Your only hitch may be whether you have the correct hardware designator.


Give it a shot first, shouldn't take long. It's all temporary unless you put it in the fstab file so you are not going to hurt anything.

Link to comment
Share on other sites

Well even though you haven't anwered my previous post I decided to give your instructions a try. I completed steps 1, 2, 4, and 4 and successfully created a new directory called zipdrive. I was confused however what to type at the command prompt in step 5 but I tried typing this:


mount -t auto /dev/sda1 /mnt/zipdrive


Then it said:


mount: /dev/sda1 already mounted or /mnt/zipdrive busy

mount: according to mtab, /dev/scsi/host0/bus0/target0/lun0/part1 is already mounted on /mnt/zipdrive


So then I typed this:


ls /mnt/zipdrive and it listed a whole bunch of stuff like:


arcldr.exe ffastun.ffl

arc.setup.exe ffastun.ffo


boot.ini linspirelive-4.5.602.iso


There were other entries as well but I won't list them. At first I didn't know what I was looking at cuz none of that stuff is on my zip disk. But when I saw linspirelive, SimplyMEPIS, Mandrakelinux-Move, and SUSE-Linux I realized that I must be looking at the contents of my external USB hard drive, not my zipdrive, cuz I downloaded 4 .iso images of different Linux distributions and saved them to my USB drive. So why is it showing the contents of my USB drive instead of my zipdrive? How do we fix it so it shows the contents of my zip drive? My only guess is that sda1 is the name of the USB drive, not the zipdrive. And of course what I really want to do here is to be able to access the contents of both my zip drive and my USB drive through icons on the desktop, so how would I do that?

Edited by 357mag
Link to comment
Share on other sites

Your guess is accurate. SDA1 is probably your USB drive. If you can figure out the designator for your zipdrive, then you will be able to mount that as well. What it broils down to is:


1. Provide a mount point (a folder)

2. issue the mount command

3. Check the results.


Once you know where everything is located, you can now create fstab entries for them and make the process automatic.


Unfortunately I'm not very familiar with zips and linux. Not sure what the designator would be. Might want to do some googling with keywords like zipdrive linux so on..


Another note..


If you reboot, you can reset all the mounts and start over with your investigation.


You can also type


umount /mnt/zipdrive


and it will unmount the drive. Note that there is no N after the u (who knows why?)


You can then verify that its unmounted by checking the folder contents and the files you saw should be gone.


Also, maybe you should drive sda2 instead of sda1, try some playing around.. Back to work for me..

Link to comment
Share on other sites

Well this is strange. I reproduced the steps I took to create a folder called zipdrive and finally issued the mount command:


mount -t auto /dev/sda1 /mnt/zipdrive


And now it says:


mount: special device/dev/sda1 does not exist


And I sure I typed everything exactly as I had done before. I was going to try out using different names like sda4 or something but now I can't even reproduce what I had done before.

Link to comment
Share on other sites

I did a google search for


linux zip drive


and found this..




Try typing into the command window..



<- root password


(click ok on the warning alert)


You should have a graphical display of all of your partitions including your zip drive and possibly your usb drive.


I think you are getting close, and proably learning a bit too :beer:

Link to comment
Share on other sites

Well I'm logged in as root and I typed diskdrak and it just says "command not found". So that didn't work. And I still don't understand why I can't reproduce what I had done before? I followed the same steps, of creating a new folder, checking to see if the new folder exists, and issuing the mount command but it keeps coming back with "special device/dev/sda1 does not exist." It simply makes no sense, cuz the first time I went through those same steps at least I saw the contents of my USB drive. According to the File Mangager, under the Hardware icon Mandrake calls my zip drive hdb1 so I tried issuing the command with that, and I heard the zip disk spin but thats all it did. It still did not show the contents of the disk.

Link to comment
Share on other sites

Well I finally got it to work. It typed in mount -t auto /dev/hdb4 /mnt/zipdrive and it said that /dev/hdb4 was already mounted so then I typed ls /mnt/zipdrive and then it showed the files on my zip disk.


But now the questions are:


1. What specifically do I type in the /etc/fstab file?

2. How do I go about creating an icon representing the zip disk so when I click on it it opens up the contents of the disk? And this is strange too. Actually there is an icon now for the zip drive on my desktop but I don't know how it got there!

Link to comment
Share on other sites

But now the questions are:


1. What specifically do I type in the /etc/fstab file?

2. How do I go about creating an icon representing the zip disk so when I click on it it opens up the contents of the disk? And this is strange too. Actually there is an icon now for the zip drive on my desktop but I don't know how it got there!



Your first question someone else will have to answer, cuz i donno. BUT, Mandrake is set up to automatically create an icon for some mounted devices on the desktop when they are mounted and then remove the icon when they are unmounted. (Kind of smells like Macintosh :(


You can change this behavior my right-clicking on the desktop, selecting Configure Desktop ... , then the Device Icons tab and selecting which ones should show up and when.

Hope that helps :)



Edited by nchancock
Link to comment
Share on other sites

Actually it may be that since these are removable media, that you can't add an entry to fstab. But once you did the mount, it probably made an icon for you. If you unmount, does the icon go away? Try mounting/unmounting and see if the icon comes and goes.. if it does, then we just need to make you an icon that contains a command to mount. Really I'm not the best person at this point to help you with this as I don't have removable media..

Link to comment
Share on other sites

Well at the command prompt I typed both umount /mnt/zip and umount /mnt/zipdrive and nothing happened. The icon is still there, and I don't think a link has ever been established from the desktop icon to the actual drive cuz when I click on the desktop icon it just opens up a window with nothing in it and in the location box it says file:/mnt/zip.


I also tried right clicking on the blank desktop and created a new icon call zip device and chose the /dev/ide...path but when I click on it I've gotten two different error messages. If I can't solve problems like this I probably won't be switching to Linux.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...