Jump to content

Mustek 1200CP Scanner Working


Recommended Posts

Here is a list of steps I went through in getting my elderley Mustek 1200CP scanner to work on 10.0 using SANE and GIMP. I hope that at least part of it is useful to others.


1. Connect scanner to parallel port, power on, and boot up PC.

2. As root, I ran sane-find-scanner, which helpfully informed me that it would not detect parallel port scanners.

3. After some hunting, I find that I need to edit /etc/sane.d/dll.conf to uncomment the line "mustek_pp", and also edit /etc/sane.d/mustek_pp.conf to uncomment the line "scanner Mustek-1200CP 0x378 cis1200". This is duly done.

4. Run sane-find-scanner again. No luck. Undeterred, I run scanimage -L just in case. No luck.

5. Find the very helpful site http://penguin-breeder.org/sane/mustek_pp and note that the RPM version for SANE listed here (1.0.14) is more recent than the one included in the Mandrake 10.0 distro (1.0.13).

6.Download and install new SANE RPM from http://packman.links2linux.org/?action=211.

Aside - at this point I note that RPMDrake does not list sane as installed at all. (Anyone have any idea why? Kernel module, perhaps?)

7. Edited config files again.

8. Can now pass the "-p" option to sane-find-scanners but still no luck.

9. Checked operation with debug output, but with no real progress. I can at least see that the driver code is being loaded and executed, however, so the basic setup seems OK.

10. Reach dead end. Go to bed.

11. Next day, switch to Windows and go through similar tortuous process there. No luck.

12. Switch back to Mandrake and try the hardware manager. No luck - I get an "unsupported" message when I select the 1200CP from the list of available scanners. This rather begs the question of what it's doing in the list in the first place, of course...


13! The eureka moment! I realise that I have misread the port designations on the back of the scanner and have plugged the cable into the wrong port! Bang head on desk. Bang desk on head. Two year old son also learns a few more inappropriate words with which to embarrass his mother in Sainsbury's.


14. Woo-hoo. sane-find-scanners -p now finds the thing, and I can now acquire image in GIMP.

15. Image is stretched. Luckily, this is something I do know how to fix, as it is in all the Mustek FAQs - switch drivers to use 1200CP+ driver instead of plain old vanilla 1200CP, and everything is hunky-dory.


Now, I am not sure whether the new SANE RPM was really necessary, but I am inclined to think that it is, as the previous version of sane-find-scanner had no -p option which appears essential for discovery.


Anyway, I hope that the above helps someone in a similar situation.

Link to comment
Share on other sites

Thanks, Sean. I've moved it to Tips & Tricks.  :thumbs:

Well, I thought that I'd contributed enough problems to these forums and it was time to redress the balance a little... :cheesy:

Link to comment
Share on other sites

  • 1 month later...

Using this as a basis for my own experiments, I managed to get my Canon parrallel port scanner working, where on previous attempts I had failed. Thanks again, for pointing me in the right direction.


Link to comment
Share on other sites

Well, it took me almost a month to get my HP3200C parallel port scanner working on Mandrake 9.2. Here is a link for anyone else that has one of these. http://umax1220p.sourceforge.net/index.html Note the UMAX1220P is the same scanner, I guess HP had Umax make it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...