Jump to content
haagon

kphotobook

Recommended Posts

Hello there!

 

I'm trying to compile the wonderful kphotobook but it does'nt work:

./configure works fine but without explicit "run make now" message

make comletes with 2 plain errors, no comment

make install completes but no kphotobook available

 

kphotobook.sourceforge.net gives the hint to add --prefix='KDE-installation-path' which is /opt/kde3, but there is nothing like kde3.

 

Compiled with the prefix kphotobook creates some folders with icons and a DocBook-Help.

 

A search with konqueror for "kde3" returns /usr/lib/kde, but this folder contains *.so- and *.la-files and a plugin-folder.

 

Did anybody successfully compiled kphotobook? Where is kde3 installed? Are there rpm's already?

 

PS: I'm using MDK 10.0 CE with installed Includes, which is neccessary for kphotobook.

Edited by haagon

Share this post


Link to post
Share on other sites

You should set:

 

--prefix=/usr

 

MDK does not use /opt/kde3

 

KPhotobook indeed looks nice :-)

No rpm as far as I know, for 10.0 OE.

 

But digikam is a killer application ;-)

 

# urpmi digikam digikam-plugins

 

Good luck!

 

p.s. welcome on mandrakeusers.org

Edited by anna

Share this post


Link to post
Share on other sites
kphotobook.sourceforge.net gives the hint to add --prefix='KDE-installation-path' which is /opt/kde3, but there is nothing like kde3.

 

i have never tried to install kphotobook, but i have run into this problem with other KDE apps. the above "hint" tells you to use the KDE installation path switch during install. but........ MDK installs KDE differently than alot of other distros, so the above "/opt/KDE" path will be incorrect. instead, try one of the following...........

 

--prefix=/usr

 

if that don't work........

 

--prefix=/usr/share

 

or (if that don't work).......

 

--prefix=/usr/share/apps

 

Chris

Edited by chris z

Share this post


Link to post
Share on other sites

Thanks for your anser!

You should set:

--prefix=/usr

Yup, i should, i did and i got: Good - your configure finished. Start make now

So did i and got back my 2 errors:

uic: File generated with too recent version of Qt Designer (3.3 vs. 3.2.3)

make[3]: *** [settingstagtree.cpp] Error 1

make[3]: Leaving directory `/home/marx/kphotobook-0.0.6/src'

make[2]: *** [all-recursive] Error 1

make[2]: Leaving directory `/home/marx/kphotobook-0.0.6/src'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/home/marx/kphotobook-0.0.6'

make: *** [all] Error 2

Something with Qt? Or the Compiler?

 

MDK 10.0 uses libqt-3.2.3-15mdk, does kphotobook use another one?

 

PS: I'm tring DigiKam so far. Thanks. It's very fast.

Share this post


Link to post
Share on other sites

it looks like the version of kphotobook you're trying to install was built against KDE3.3, which uses QT3.3. try going HERE & download & install the older version kphotobook-0.0.5.tar.gz.

 

Chris

Share this post


Link to post
Share on other sites
it looks like the version of kphotobook you're trying to install was built against KDE3.3, which uses QT3.3. try going HERE & download & install the older version kphotobook-0.0.5.tar.gz.

I have the same suggestion. I tried 0.0.5 but it's the same error. Mandrake 10.1 comes along with KDE 3.2.3, for Members - unlike me - KDE 3.3. Well, wait or pray? But how did others compile? Can i update KDE to Version 3.3?

 

System reconstruction only for one application, this can't be the solution. So I use digikam, thanks Anna.

And thanks chrisz!

 

Haagon

Edited by haagon

Share this post


Link to post
Share on other sites
So did i and got back my 2 errors:

    uic: File generated with too recent version of Qt Designer (3.3 vs. 3.2.3)

 

QT version and compiler should be okay.

A possible fix was posted on kde-apps.org.

 

In the /src directory there are 6 .ui files, each of them starting with a line:

 

<!DOCTYPE UI><UI version="3.3" stdsetdef="1">

 

Replace in all files the version="3.3" with version="3.2.3" ...

 

Wonder if this would do it. :unsure:

 

And did you first: make uninstall and make distclean before starting a new compilation?

 

As of kde 3.3. in MDK 10.1 - the rpm's not yet functional for MDK. And the 3.2.3 version is very good, what I can see on my test system, no need for 3.3. ;-) the biggest improvements were made in the kontact suite, and these rpm's are the 3.3. versions on 10.1.

Share this post


Link to post
Share on other sites
QT version and compiler should be okay.

A possible fix was posted on kde-apps.org.

In the /src directory there are 6 .ui files, each of them starting with  a line:

<!DOCTYPE UI><UI version="3.3" stdsetdef="1">

Replace in all files the version="3.3" with version="3.2.3" ...

Yup, that's it! A little bit tricky ...

And did you first: make uninstall and make distclean before starting a new compilation?

I did the uninstall-thing but not distclean, now i know !

 

Thanks Anna!

 

Haagon

Share this post


Link to post
Share on other sites
You might want to check out gthumb as well. It works perfect for me.

OK, urpmi gthumb .... well, nice app, but i like hierarchical tagging better. By the way, compiling kphotobook wasn't perfect: only title and boolean tags available. Maybe something with the make distclean thing. I'll try again with mdk 10.1 later.

 

Ciao Haagon

Share this post


Link to post
Share on other sites

hi haagon,

 

would you mind building an rpm for kphotobook?

It looks very nice, and I am new to Linux and Mandrake, and don't know how :unsure:

 

_______

jonas

Share this post


Link to post
Share on other sites
would you mind building an rpm for kphotobook?

It looks very nice, and I am new to Linux and Mandrake, and don't know how  :unsure:

______

jonas

Well, i thought about it but i haven'n done it yet - and kphotobook is still not running complete.

but compiling is not difficult: unpack the tar-archive change into the new directory, open a shell, type ./configure --prefix=/usr ,wait and watch, if you get something like *run make now* just type make, then become superuser and type make install. Give it a try!

But if it fails, run make uninstall and make distclean, maybe its better...

 

If i built a .rpm, i post a message.

 

Bye

 

Haagon

Share this post


Link to post
Share on other sites

Well, Mandrake 10.1 was not the solution. Some other errors ...

 

By the way, i switched to xfce4 and was looking for a gtk-based Pic-Browser.

Sitor recommended gthumb, which is now my first choice. (But its still too slow and not enough drag'n'drop ...)

 

Maybe someday there is a second chance for kphotobook ...

 

Thanks Anna, Chris Z and sitor! Jonas, keep on trying!

Bye, Haagon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...