Jump to content

"start new session" button [solved]


Recommended Posts

Actually, it's not that its irritating, it's bcoz, when I left my computer with 'd desktop locked, some of my officemate will try to hit this button, and as I've said, my pc is not that strong to handle multiple desktop session........ it's a good feature like that of XP but I dont need it right now, any ideas?

Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...

I found an alternative on how to make it happen that the "new session" option will not appear when locking the desktop, also it will not appear in the Mandrake start menu. Thatś when using the XDM instead of KDM or mdkKDM. I tried it but I changed it back to kdm coz some applications installed alredy in my systems does not function anymore...wierd.. anyway, I still think that there's a right config file that could be edit in-order to solve my little problem.. just dont know it yet.. or maybe I'll just try to figure it out why I encountered some probs.. when changing DM.. its another issue

Link to comment
Share on other sites

This will remove the Start New Session menu item under Actions. Does this help you?


The /etc/X11/xdm/Xservers file has been edited and "-nolisten tcp" added for security reasons to prohibit access through port 6000. The remaining 1-5 items have been commented out, meaning only one X session is possible.


:0 local /usr/X11R6/bin/X -deferglyphs 16 -nolisten tcp

#:1 local reserve /usr/X11R6/bin/X :1 vt8 -deferglyphs 16

#:2 local reserve /usr/X11R6/bin/X :2 vt9 -deferglyphs 16

#:3 local reserve /usr/X11R6/bin/X :3 vt10 -deferglyphs 16

#:4 local reserve /usr/X11R6/bin/X :4 vt11 -deferglyphs 16

#:5 local reserve /usr/X11R6/bin/X :5 vt12 -deferglyphs 16


:0 local /usr/X11R6/bin/X -deferglyphs 16

:1 local reserve /usr/X11R6/bin/X :1 vt8 -deferglyphs 16

:2 local reserve /usr/X11R6/bin/X :2 vt9 -deferglyphs 16

:3 local reserve /usr/X11R6/bin/X :3 vt10 -deferglyphs 16

:4 local reserve /usr/X11R6/bin/X :4 vt11 -deferglyphs 16

:5 local reserve /usr/X11R6/bin/X :5 vt12 -deferglyphs 16

Link to comment
Share on other sites

thanks, but i have tried that, I mean for KDM, coz i used KDM, not XDM yet, but I also tried your suggestion... but still not working under KDM. in my previuos post, when setting default DM to XDM, it solved my problem... coz the default in XDM does not display "Start A new session" button... well, I've said also that I got some problem when using XDM, when playing on it, I found out that when I changed from KDM to XDM, my bash_profile was reset to default, so those installed under /usr/local/ and those script under /usr/local/bin/ does not work anymore... so I have to add those to my local users path = $PATH to correct the problem then, and it does... so by setting the DM to XDM solves my problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...