Jump to content
Sign in to follow this  
DruManiac

Speedtouch 330 ADSL Modem MDK10

Recommended Posts

hey everyone... here is the problem:

 

my modem was working perfectly on 9.2 then i upgraded to 10 and ive tried 3 different firmwares but it still doesnt connect... harddrake indentifies my modem but when i setup a connection and try to connect, it says "the system doesnt seem to be connected to internet"

 

why would that be?

 

[moved from Hardware and edited by spinynorman]

Share this post


Link to post
Share on other sites

More info please.

Did you upgrade a Mandrake installation or Install 10 from the beginnning.

 

Type of speedtouch? 330 is this USB?

 

Who is your provider?

 

You are from Turkey and your are now in Switzerland?

Was it working in Turkey for instance? But n not in Switzerland. = Differenet VCI VPI numbers.

 

Have you changed username with your provider but not in /etc/ppp/peers/adsl

 

(May be different location on your system)

 

In /etc/resolv.conf or /etc/ppp/resolv.conf do you have any values set for name servers?

 

Have you changed your password with your provider but not in /etc/ppp/chap-secrets or pap-secrets?

 

If everything seems right try as root pppd call adsl and take note of any error messages.

 

If you have tried to set it up to start at boot try as root /etc/init.d/ speedtouch start

 

Take a note of any error messages.

 

If you get the message that failed xxxx module could not be found it's because kernel 2.6 does things differently!

 

run lsmod to find out what modules you are loading. Your looking for usbcore theres a list usb comes in several flavours ohci uhci ehci what you need depends on where your speedtouch is plugged in I have all three types running on this machine!

 

Find /etc/speedtouch.conf

 

edit the line

 

DEFAULT_USBINTERFACE="usb-xxxx"

 

to read

 

DEFAULT_USBINTERFACE="xxxx-hcd"

 

Be careful backup the file before you start.

 

Try

 

as root /etc/init.d/ speedtouch start see if anything happens.

 

If you aren't specific I can't help.

Edited by willisoften

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...