Jump to content

Mandrake 10.0 & eth0

Guest -Nash!-

Recommended Posts

Guest -Nash!-

First of all, i wanna say "Hi" :D


I'm quite new to Linux (to be precise, i installed it yesterday for the firs time).

Installation went without probs after the 3rd time i tried it.

It always freezed on me. I noticed that it freezed after i've moved my mouse a bit (Microsoft Intelli Explorer 3.0).


Anyway, it's installed now. Working fine except one thing: the network device.


- Realtek Semiconductor Co. Ltd. RTL -8139/8139C/8139C+ (vex. 16)

- IRQ 12

- Master Capable. Latency=32. Min Gut=32. Max Lat=64

- I/O at 0xb000 [0xb0ff]

- Non-prefetchable 32bit memory at 0xd5000000 [0xd50000ff]

(a straight copy&paste from "ifconfig")


It seems like the module isnt loading at all.

Checked "lsmod" for any entries containing "rtl", nothing found.

Checked for the modules in /lib/modules/2.6.3-7mdk (not sure about that. Just entered the kernel version)/kernel/drivers/net/ :

2 Files found in there:





"modprobe" gave no error, so i tried to compile them (/insmod 8139too).

It gave me a "no such file or directory" error.


I also checked the (/boot)/config file for "8139" entries:




#CONFIG_8139TOO_PIO is not set



#CONFIG_8139_OLD_RX_RESET is not set



Anyone knows how to solve this problem? :wall:

As i said, i'm totally new to linux. Some friends helped me during the install (in IRC).


Any help is very appreciated B)





/EDIT: The Hardware Option in "drakconf" crashed on me :\


/EDIT2: ifconfig and lsmod.

Might help =)

Edited by -Nash!-
Link to comment
Share on other sites

put the output of lsmod here!!


edited to say: BTW. With lsmod, check if you have any eth1394 module. If positive get rid of it.

reboot the system and type in a terminal:

rmmod eth1394

Afterwards, try to get internet conection.

Edited by william
Link to comment
Share on other sites

Yes MDK10 has pretty fuzzy networking wizards. Its best to use another thing to configure such as webmin or do it manually by editing the files.


Its very hard to get working if mandrake doesn't recognize it from there. Unfortuatly I can't help you much more then this.


Just try picking the right networking driver, (MDK normally finds the right one)

and set it up manually.


Best Of Luck,


Link to comment
Share on other sites

The module is loaded (8139too), and the eth0 interface is appearing in ifconfig, so it is looking good.


What exactly is your problem - you cannot connect to the internet? Or cannot get on your LAN?


How are you connecting to the internet - adsl modem? Have you a router? Or are you connecting through dial-up?


Please post your hardware setup - looks like you are nearly there :)



Link to comment
Share on other sites

Guest -Nash!-

Alrite, i can now connect to the Inet.

Don't aks me why it's working now, no clue :o


But there's still another annoying prob:


When i boot up Mandrake, it stops at "activating >eth0< interface" (prolly a poor translation :P)

Well, it gives an "Error" but keeps going.


Aynone knows how to solve that?

Link to comment
Share on other sites

If it stops (for about 20 seconds?) and then carries on, it is probably looking for a DHCP server to allocate it an address. The easy solution is to set it up with a static address, or perhaps try turning on any modem/router you may have that is running a DHCP server, waiting a little, then turn on your PC.


If it doesn't stop while booting, but you are just getting an error message, I would ignore it :)



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...