Jump to content
Sign in to follow this  
xboxboy

Guidance With Script?

Recommended Posts

Hi all.

 

It seems I can not sort out my raid array boot issue, so I'll have to settle on a work around.

 

I need to run 2 commands each boot. These are:

 

# Raid array discovery and activation
dmraid -ay

# Mount arrays for access
mount /dev/mapperxxxxxxxx /mnt/mount_point

 

Is it as simple as creating a bash script and then placing it somewhere so as to be executed or is there another process? All this in new to me.

 

Thanks

Share this post


Link to post
Share on other sites

What exactly is the problem? Why do you need to run it?

 

The command you are using is similar to what I would have used to activate and scan LVM's to activate volumes:

 

vgchange -a y

 

which obviously then allows me to mount them. Let me know more about your problem, so I can help with your boot issue. I expect something with initrd, or some grub config perhaps.

Share this post


Link to post
Share on other sites

Hi Ian.

 

Using the live CD's and DVD the arrays are detected. After install the arrays are NOT detected, but all the hard disks are shown.

 

For some reason the Mageia's (I can confirm this occurs for mageia 2 and 3) fail to find and/or activate my raid arrays when installed. The arrays are motherboard based Intel Storage Matrix. I can confirm I have had no trouble using Mandriva with these arrays.

 

So to access them I need to boot, then run the DMRAID to activate them, then I have to mount them.

 

I, too, believe it is an initrd issue. From the irc channels I have tried mkinitrd and dracut without success.

 

I originally had hoped to fix it during boot, but I don't understand the boot process enough. So that's why I was looking to just automate a script after boot.

 

I would prefer to activate and mount them prior to bringing up x then at least Dolphin can be configured to show these raids as 'places', as one array holds all my data and the second all my movies and music.

 

Any help towards settling this issue is greatly appreciated.

Share this post


Link to post
Share on other sites

Ok. The deal is mdadm is supposed to manage intel motherboard/bios raid these days. So it turns out that intel bios raid (named isw_*) are filtered out past dmraid, where mdadm should take over.

 

Well, dmraid has worked fine for me in the past, so let's allow dmraid to operate the array:

 

/lib/systemd/fedora-storage-init

#			if [[ "$dmname" == isw_* ]] && \
#			   ! strstr "$cmdline" noiswmd; then
#				continue
#			fi

 

I commented out those lines, and dmraid activates the arrays, fstab can mount them. Only issue is, apparently on some updates I will need to redo the adjustment to that file.

 

I since found mdadm isn't even installed on my system. Bug has been reported.

 

Thanks to David over in #mageia-dev irc channel for the help on this one.

Share this post


Link to post
Share on other sites

I guess that as mdadm isn't installed, this means that dmraid has been used to configure/create/manage your arrays. However, if you need mdadm and it isn't installed, simply install it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...