Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
AussieJohn

Dell XPS Gen3 Desktop

Recommended Posts

Hello everyone,

I am here in Maine, USA. at the moment and working on a computer loaned to me by my host friends. I'll be here for 8 weeks. I have installed Mageia-1 on it and am using a wifi adapter to connect to their cable modem. Setup works AOK. I cannot find a way to disable the onboard LAN. I have removed the LAN cable but it keeps showing up in the Internet connections and seems to prevent the machine from setting up the wifi connection. Thus it has to be done manually each time the computer is rebooted.

On my machine at home I found this to be necessary and would like to set this up the same way.

 

Cheers. John.

 

 

[moved from Hardware by spinynorman]

Edited by AussieJohn

Share this post


Link to post
Share on other sites

Thanks Daniel, for your post.

I had already hunted through the Bios but could not find any reference to the LAN anywhere. Hence my plea here. This is not to say that it isn't there because I may just be missing it somehow.

The Bios is a weird basic layout of the kind that I remember used to be in computers 10 years ago, very much retro and not very helpful.

I hope someone with Dell machine experience might give me a clue here. I hope. :-)

 

Cheers. John.

Share this post


Link to post
Share on other sites

I'm not sure how the connection is being managed, but check /etc/sysconfig/network-scripts/ifcfg-eth0. In this file there will be an onboot option or similar which can be set from yes to no and then it shouldn't become active. That should at least let you get around it if the option in the BIOS doesn't exist as not all computers have it.

 

Alternatively, configuring the eth0 connection in MCC should give you the option of disabling it without it enabling onboot.

Share this post


Link to post
Share on other sites

Thank you Ian That did the trick. :thumbs:

I used to do the usual routine of using MCC to disable but it would never hold through a reboot.

It does now. There is no LAN message that ethernet is down. There is just a short pause and then the wi-fi connection comes up as one would expect..

 

Cheers. John.

Share this post


Link to post
Share on other sites

I spoke too soon. After I made the suggested change to the file, I rebooted and it worked but later on I rebooted again and the problem was back.

I checked the file and it was still as I had changed it. I also went into MCC to remove LAN connection again since it has appeared in here once more, Rebooted and still have same old problem. :wall: :wall: :wall:

 

John.

Share this post


Link to post
Share on other sites

We can also blacklist the kernel module for the ethernet card that way the device will never appear. Usually under /etc/modprobe.d and create a new file but of course we just need to find out what module is being loaded for that particular card.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×