Jump to content

Parallel printer support dropped? [solved]


Recommended Posts

I am looking for someone with a parallel port and printer to confirm that an updated Mandriva 2010.0 or 2010.2 system will not recognize a new parallel printer.


If you have an installed and working parallel printer I'd suggest that you don't uninstall it because you may not be able to reinstall it, however if you have an uninstalled parallel printer at hand then I would like to know what happens when you try to install it on an updated 2010.0 or 2010.2 system.


I have a laptop running 2010.0 which used to recognize parallel printers. I keep this computer updated with all the latests packages and kernels. I suspect that one of these updates broke parallel printer recognition. This happened about the time of the recent change of Mandriva ownership.


Same problem with my desktop which (if I recall correctly) used to recognize parallel printers when I first installed 2010.1. I keep this desktop up to date, at some point it updated to 2010.2 and it may have been about that time when the printer recognition problem appeared.

Edited by boatman9
Link to comment
Share on other sites

Apparently I don't have the same problem described in that bug report. I did not find any "parport_pc 00:0b: disabled" in /var/log/messages and the "modprobe parport_pc" work-around did not work for me.


Although my /usr/share/hplip/data/models/models.dat has attributes listed for both the hp_deskjet_710c and hp_deskjet_712c I found the following in /var/log/messages

Feb 15 20:08:39 localhost python: io/hpmud/model.c 528: no DESKJET_710C attributes found in /usr/share/hplip/data/models/models.dat
Feb 15 20:08:39 localhost python: io/hpmud/model.c 539: no DESKJET_710C attributes found in /usr/share/hplip/data/models/unreleased/unreleased.dat
Feb 15 20:08:39 localhost python: io/hpmud/pp.c 1242: ignoring hp:/par/DESKJET_710C?device=/dev/parport0 support=0


After booting with the HP 712C printer connected I find the following lines in dmesg:

parport_pc 00:09: reported by Plug and Play ACPI
parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
parport0: Printer, HEWLETT-PACKARD DESKJET 710C
ppdev: user-space parallel port driver

Link to comment
Share on other sites

I found a way to configure the parallel printer. On my laptop running Mandriva 2010.0, the printer happened to be disconnected from the printer port when I ran the MLCC printer configuration tool and clicked on New to add a new printer. This was a chance occurance, and turned out to be a lucky strike for me because suddenly I saw "LPT #1" appear as the top choice under the "Select Device" heading. Strangely, "LPT #1" appears only when their is no printer connected to the parallel port, but even then it doesn't always appear. The appearance of the "LPT #1" choice allow me to setup the printer, and afterwards I noticed that the printer's Device URI is: parallel:/dev/lp0


Infused with new hope I went over to my desktop running Mandriva 2010.2, but I was unable to get the "LPT #1" choice to appear no matter if the printer was connected or not. Fortunately I was able to install the printer by selecting "Other" and manually entering the device URI as: parallel:/dev/lp0

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...