Jump to content
Sign in to follow this  
pindakoe

Difficulty reading MP3 from CIFS (Samba) share

Recommended Posts

I have collected a bunch of MP3 and put them on my NAS (Bubba -- running Debian). Below is output of /proc/mounts for the share in question:

 

//bubba/home /home/pindakoe/bubba cifs rw,mand,relatime,unc=\\bubba\home,username=pindakoe,uid=1001,forceuid,gid=100,forcegid,addr=192.168.0.2,file_mode=0755,dir_mode=0755,serverino,rsize=16384,wsize=57344 0 0

> ls -ld bubba/
drwxr-xr-x 1 pindakoe users 0 2010-07-05 18:57 bubba//

 

The UID/GID options are passed to ensure that UID/GID match between my Linux box and the NAS.

 

I have some sort of weird access issue if I try to get the ID3 tag info when files are on the NAS: mp3info complains about a missing ID3 tag and corrupt info at end of file; Thunar only shows an empty tag. Alsaplayer can read the file, but refuses to play it ('no stream; the module for mp3s cannot open the file). Audacious opens the file and plays it. I can copy the files from the NAS to my HD and mp3info, Thunar, alsaplayer work OK; the file is complete (including tags) and plays normally. Anybody who has got a clue where this issue comes from?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...