Jump to content
Sign in to follow this  
M_R

Annoying warning when copying to NTFS [solved]

Recommended Posts

Hi,

 

 

I'm getting a really annoying warning in Dolphin when I copy anything to a NTFS partition mounted in /mnt/windows. The files are copied and everything is right, but if I copy a folder containing 300 files I'll have to click on accept 300 times!

 

The warning says "Could not change permissions for FILENAME".

 

 

* I tried the silent option in fstab but it didn't work.

* This is the fstab entry:

 

 

# Entry for /dev/sda6 :

UUID=877148664FEFB610 /mnt/windows ntfs-3g defaults,umask=000 0 0

 

Any ideas?

 

I formatted that partition once and had to configure it from MCC again as it was failing to mount it. Now it mounts and everything is right except for that...

 

Oh, I forgot to say that this does not happen if I'm root.

 

 

Any ideas?

Edited by M_R

Share this post


Link to post
Share on other sites

Try with umask=0 instead of umask=000 - I remember I had umask issues in the past before, or that I simply didn't have access to copy, but then umask=0 was OK. I haven't checked to see if there is a difference between umask=0 or umask=000 so maybe not. Other alternative, is to remove the defaults option and the comma before umask and then try that after unmounting and mounting again.

Share this post


Link to post
Share on other sites

Got it!!

 

 

The problem seems to be the absence of a locale parameter.

 

 

Before:

UUID=F2EAD096EAD05905 /mnt/windows/ ntfs-3g defaults,umask=000 0 0

 

After:

UUID=F2EAD096EAD05905 /mnt/windows/ ntfs-3g locale=es_CO.UTF-8 0 0

 

In my case, it's the locale for Spanish.

 

All is well now.

 

Thank you Ian :)

 

 

Oh wait. The problem continues:

 

I was wrong, the problem is umask, not locale. If umask is present, the error comes back.

 

Now, the problem is that if I remove it, umask somehow reappears. I'm not sure what creates it, but there is something restoring the option umask=000. Dou you know what could be recreating this parameter?

Edited by M_R

Share this post


Link to post
Share on other sites

udev maybe, but try umask=0 instead in fstab, see if it helps.

Share this post


Link to post
Share on other sites

UUID=F2EAD096EAD05905 /mnt/windows/ ntfs-3g user,defaults 0 1

should be enough to get rid of any annoying messages.

You don't have to define locale, unless the ntfs filesystem locale is different than the default one of your system.

Share this post


Link to post
Share on other sites

umask=0 keeps giving me the error "unable to change permissions for -----".

 

 

I find that removing umask solves the problem, but it appears again later.

Share this post


Link to post
Share on other sites

OK, I have more information now: no umask parameter works for me, only deleting umask works, but it comes back after reboot.

Share this post


Link to post
Share on other sites

If you have ext3 partition, just lock the file:

 

chattr +i /etc/fstab

 

then it won't be modified after reboot. Of course, edit it first, then lock it.

Share this post


Link to post
Share on other sites

If you have ext3 partition, just lock the file:

 

chattr +i /etc/fstab

 

then it won't be modified after reboot. Of course, edit it first, then lock it.

 

Umm, but I have ext4...

Share this post


Link to post
Share on other sites

So it should apply with ext4 as well. Try it.

Share this post


Link to post
Share on other sites

So it should apply with ext4 as well. Try it.

 

OK, I'll try, but how do I unlock it, just in case I want to change something later?

Share this post


Link to post
Share on other sites

Unlock with -i:

 

To lock:

chattr +i /etc/fstab

to unlock:

chattr -i /etc/fstab

Share this post


Link to post
Share on other sites

Unlock with -i:

 

To lock:

chattr +i /etc/fstab

to unlock:

chattr -i /etc/fstab

 

Thanks Ian, worked like a charm :). But, do you have any idea of what is modifying the file?

Edited by M_R

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...