Jump to content
Sign in to follow this  
Guest beginner44

No access to Windows partitions in 2010 Beta

Recommended Posts

Guest beginner44

Hello,

 

I am trying the 2010.0 Beta with a full install. I can't access my Windows XP NTFS partitions at all.

 

Is this a bug, is this normal? Can I do something about it?

 

I am a beginner (experienced but still beginner) and I don't know about "mounting" the drives. The right click menu says "mount" the drive, and I tried it but nothing happens. Is it about "miunting" the drives? (I don't even know what that mounting is).

 

Thank you in advance.

 

 

[moved from Installing Mandriva by spinynorman - welcome aboard :)]

Share this post


Link to post
Share on other sites

I was able to mount a Windows 7 RC1 partition by adding the following to fstab. There may be other ways to do this, but at least this works.

 

# Entry for /dev/sdb2: 
UUID="BE10805710801893" /mnt/windows_7 ntfs-3g defaults,umask=000 0 0

 

I used the fdisk -l (that is a lower-case letter L) command to get the partition information needed.

[root@localhost ~]# fdisk -l

Disk /dev/sda: 60.0 GB, 60011642880 bytes
240 heads, 63 sectors/track, 7752 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
Disk identifier: 0xcccdcccd                     

  Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        4086    30890128+   7  HPFS/NTFS
/dev/sda2            7098        7752     4951800   1b  Hidden W95 FAT32
/dev/sda3            4087        7097    22763160    f  W95 Ext'd (LBA) 
/dev/sda5            4087        5453    10334488+  83  Linux           
/dev/sda6            5454        5731     2101648+  82  Linux swap / Solaris
/dev/sda7            5732        7097    10326928+   b  W95 FAT32           

Partition table entries are not in disk order

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xdfbd9c43

  Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sdb2              13       12762   102400000    7  HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sdb3   *       12762       12787      204800   83  Linux
Partition 3 does not end on cylinder boundary.
/dev/sdb4           12787       19457    53577720    5  Extended
Partition 4 does not end on cylinder boundary.
/dev/sdb5           12787       19457    53576704   8e  Linux LVM
[root@localhost ~]#

 

Once I determined that /dev/sbd2 was the partition I wanted to mount, I then used blkid command to get the UUID#.

[root@localhost ~]# blkid
/dev/sda1: UUID="1EA4E764A4E73D41" LABEL="IBM_PRELOAD" TYPE="ntfs"
/dev/sda2: LABEL="IBM_SERVICE" UUID="460C-3761" TYPE="vfat"
/dev/sda5: UUID="6fac9d46-945f-11dd-b256-a7f53cf1e588" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda6: TYPE="swap" LABEL="swap" UUID="660bb819-4642-4832-9efd-024ca14b6287"
/dev/sda7: UUID="488F-0C33" TYPE="vfat"
/dev/sdb1: UUID="6AAC73BDAC7381FD" LABEL="System Reserved" TYPE="ntfs"
/dev/sdb2: UUID="BE10805710801893" TYPE="ntfs"
/dev/sdb3: UUID="fe7a3d5e-a100-437e-8014-ea945d7cdba0" SEC_TYPE="ext2" TYPE="ext3"
[root@localhost ~]#

 

I used the mkdir /mnt/windows_7 command (choose whatever name you like for a folder under /mnt/) to create the mount point.

[root@localhost ~]# mkdir /mnt/windows_7
[root@localhost ~]#

 

Now add the lines to /etc/fstab. I appended the ntfs-3g defaults,umask=000 0 0 part of the line from information I got elsewhere.

# Entry for /dev/sdb2: 
UUID="BE10805710801893" /mnt/windows_7 ntfs-3g defaults,umask=000 0 0

 

If you have a fat partition, then this line would be a little different. Instead of ntfs-3g, you would use vfat. I have the following line for a fat32 partition that exists on my drive.

# Entry for /dev/sda7 :
UUID=488F-0C33 /mnt/win_d vfat umask=000,iocharset=utf8 0 0

 

You may need to install ntfs-3g. You will need to reboot for changes to take effect.

Share this post


Link to post
Share on other sites
Guest beginner44

Dear David, thanks a lot for your great help. But unfortunately that is Chinese to me... :wall:

 

I will follow your suggestion of installing the final version tomorrow (silly me I didn't notice it was coming out so soon) and see what happens because the previous versions of Mandriva did recognize and access my Windows XP partitions.

 

However, I have a big problem with all the Linux distros I try and Mandriva is no exception. When I install them they run fast. Even after running all the updates. But after a while, they start getting deadly slow and even buggy. Mostly Firefox (and the other browsers which are worse in my opinion). It all gets slow, freezes, fails... All distros. And only after a few hours of use. I have tried a million things like using a simple base theme, unchecking some start up programs, uninstalling some heavy programs like OpenOffice... nothing. It always becomes deadly slow and buggy. I was it's me doing something wrong as I am a beginner but I don't know what it can be.

 

If you had some ideas please let me know.

 

Thanks a lot again.

 

Regards.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...