Jump to content
cartergsx

Update gone wrong. [solved]

Recommended Posts

HI, a little help to a Newbie from you Guru's out there.

I've been running '2009' free version ok for ages, until the

'Install updates' drop down appeared. Clicked on the update now all I get when I try to open 2009.1 is a black screen with a flashing curser in top left corner.

thanks, CARTER still learning.

Share this post


Link to post
Share on other sites

press Ctrl+Alt+F1 which hopefully gets you to a login prompt.

 

login and then type"startx"

 

If you tell us the error messages you see on the screen, someone here can help you.

Share this post


Link to post
Share on other sites

you should be able to enter you password, but no letters or symbols will show. Just type your password correctly and press enter

Share this post


Link to post
Share on other sites

you should be able to enter you password, but no letters or symbols will show. Just type your password correctly and press enter

 

 

Thanks , did as suggested. Message reads

 

'Could not start Kdeinit4'

(EE)failed to load module "type 1" (module does not exist,0)

(EE)failed to load module "freetype" (module does not exist,0)

 

hope this helps, thanks.

Share this post


Link to post
Share on other sites

press Ctrl+Alt+F1 which hopefully gets you to a login prompt.

 

login and then type"startx"

 

If you tell us the error messages you see on the screen, someone here can help you.

 

OK, did that, error message reads

'Could not start Kdeinit4'

check installation.

I presume then that the downloaded upgrades were incomplete.

and a complete new install would be a better option.

Share this post


Link to post
Share on other sites

I would probably wait for someone who knows a little more than me to drop by and help you out. It's usually un-needed to re-install with linux.

 

It looks as though your system is ok, just that KDE4 isn't working properly. Some one should be able to help you complete the update from the command line. And then you'll be sailing smoothly again.

Share this post


Link to post
Share on other sites

Meanwhile, if you have access to the command line, you can try and reconfigure Mandriva to disable auto-login, so that you're not systematically dropped into a non-working KDE. To do this, run “startx /usr/bin/mcc"; from there, you'll also be able to install alternate desktop environments.

 

Yves.

Share this post


Link to post
Share on other sites

I would probably wait for someone who knows a little more than me to drop by and help you out. It's usually un-needed to re-install with linux.

 

It looks as though your system is ok, just that KDE4 isn't working properly. Some one should be able to help you complete the update from the command line. And then you'll be sailing smoothly again.

 

To update from the command line, login on the command line like you did before and run:

 

$ su

<enter root password>

# urpmi.update -a

 

After updating the repos, you can update all installed packages with:

 

# urpmi --update --auto-select

Share this post


Link to post
Share on other sites

Thanks Guys for your help sorting this problem. I'm up and running again.

will require a few tweeks here and there. But more importantly have learned

a little more. Thanks Again.

CARTERGSX

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...