Jump to content

2009 Install Hangs with "sr"

Ross Youngblood

Recommended Posts

I'm attempting to install the "mandriva-linux-one-2009-KDE4-int-cdrom-i586.iso"


The system gets about say 10% in , and barfs on the SCSI driver with the message

"driver 'sr' needs updating please use bus type methods" :wall:


I can't tell yet if this is an issue with that particular driver, as my RAID 1 array may be getting handled by the SCSI driver. I can't tell and really don't want to take the time to find out, but will probably have to.


Here is my Configuration.


Motherboard GigaByte MA78GM-S2HP

CPU AMD (Blah).. don't recall, it's all Marketing hype anyway IMHO with respect to numbers. If this is important, at some point I can figure it out.


I have 6GB of memory (single channel), and it happens to pass the probably simple Microsoft Memory checker... I let it do this while downloading a SUSE 11.0 distro... if that works, I'll post and indicate what I found of that install as well.


The Gigabyte Motherboard has 6EA 3Gb/s SATA ports. 5 are internal, and the sixth is at the rear panel. I have the ports configured in BIOS as the following

BIOS Settings for SATA ports (onboard PCI controller)

Ports 0-4 --> RAID controller mode

Ports 5-6 --> IDE mode (Vista likes this so I left it )


I have a RAID1 array consisting of 2EA Seagate 320Gb drives (Frys Special a year ago).

SATA0 and SATA1 are striped for redundancy in case of a disk failure.

This was running fine and currently has a corrupted Vista installation on it,

due to my foolish attempt to swap motherboards and try to do a Vista Recovery installation. Just stop me next time.

SATA2 is a 500Gb drive I bought recently to play with... I still have data I want to recover from SATA0 and SATA1.


SATA0&1 -- 320Gb RAID 1 array

SATA2 -- 500Gb spare ($69.00 special at Frys)

SATA4 -- HP DVD burner.


SATA0-4 go through the AMD RAID controller, so I'm assuming the driver thinks these are all SCSI drives or something like that... not sure yet.

SATA4 is a SATA drive, but the BIOS is set to "IDE" behavior. I haven't gotten to the bottom of what this means, but Vista boot disks don't see if it is set to RAID as the others.

Those are my peripherials... no floppy.


My goal here was to boot the distro, and install Linux on the SATA2 drive, then recover the data from the RAID array... and eventually put the installation on the RAID drives.


I've looked on various sites and people are saying "don't know why Ubuntu is so widely praised"... from my investigations over the past year, I can state that the primary reason is the successful installation on multiple machines. If the Mandriva community wants to be successful, the installs must succeed. Once a basic Linux Kernel is up and running, then the system can talk to the internet, and intelligently scan ports etc, and get going.


One possible way to do this might be to have the distro CD boot from CD, then connect to the Internet, with the users permission, the system configuration could be scanned, and then the system could be reconfigured... this would be a productive use of "cloud" computing, as the user might benefit from a successful install as the distro could be smaller as not all drivers would be on the CD/DVD. The maintainers would have a database of configurations that needed to be validated, and would know if a distro was successfully installed or not. Unsuccessful installs would be those that were scanned, but never came back and said "I'm successful". The last "I'm Successful post could be something that is automatic, or user gated... I.e. a user would say... Yes I'm happy with the distro, or No I'm still having problems. As part of a registration step.


I know this seems a bit "Microsoft" like, but I dont' see any other way for the open source community to know when a distribution installation fails. I'm sure not going to bother to "register" for every darn support forum site during this round of Linux exploration... I just don't have the time.


At any rate, if I find that the umbutu, or suse distro loads fine on my system, I'll report back, I'll also report back if I have time to figure out why this install isn't working... Primarily because I used to really like the Mandrake distributions... not so sure now, but I'm not a GNOME desktop fan. (Actually Enlightenment is my favorite desktop environment, but they broke it after rev 15 IMHO).




Link to comment
Share on other sites

"driver 'sr' needs updating please use bus type methods"


Whatever your problem is, it's not that. That's a harmless kernel message that gets printed on every single boot of Mandriva, working or not.


What else is printed at the console? Have you checked if it's not just this known issue:




? Thanks.

Link to comment
Share on other sites

Hmmm... I'm getting much farther :D

Here are the things I did.


1) Burned new iso.... which didn't help.

I didn't have a method to verify the md5 checksum. There needs to be a nifty Windows App for this. The ones I've downloaded in the past were too clunky.

I'd like to have one where I just double click on it and it just works... or drag and drop a iso into it... something easier than lots of mouse clocks.

(At the moment the only system I have up is a Windows XP Professional system.) How about a Java applet that does MD5 checksums... anyone?


2) I changed two options on the install screen that seemed to make a world of difference.

1) Changed to "Text" mode so I could what was going on

2) Changed the pci mode to "no--something"

This may have helped my SCSI driver issue problem.


The system booted in "Live" mode this time, and I was able to select Live install, and I'm currently partitioning the 500Gb drive leaving a Vista partition alone.

This should be "Interesting".



Link to comment
Share on other sites

Hi Adam,

Thanks for the fast response. I found your blog earlier today and found you are up in Vancouver BC. I'm down in Portland...

I may not have been clearer earlier... I expected that the error may have been a harmless kernel message, but since the mode I was installing in didn't spit anything out prior to that or after that, I couldn't quite tell what was going on. I changed to text mode to try and get a better handle on the process, and also added a pci option noxxx where xxx= something... I'm in the middle of a Live Install now, so need to go back to the boot screen to find out what my pci options were.


With those two changes... it dropped into a nice X-window session (very pretty), and had a Live-Install icon. Thats where I wanted to go, so I clicked on it. So far I'm enjoying a lot of nice photographs as it... (hmmm maybe thats just a screen saver! !DOH).... as it asks me about deleting packaes.


I'm trying to get real work done while I do this.


I guess the big question I have now... is what was the hang, and perhaps if I do a text mode install without the pci probe option I had set, I can find out where the original hang was as a datapoint.. the idea is that a newbie user might not try any of the options. I'm not sure about the menu presentation of the first splash screen, but the KDE environment after the Live CD boots up is certainly very nice, and the install from that point on seems marvelous.


Thanks for the terrific support!


I'm assuming its a dirty thankless job, and unfortunately no one "has" to do anything for open source work. :)

Link to comment
Share on other sites

I re-tried again, and this time just specified "Text", it installed the Live Distro fine. I had to do it again anyway because I told the installer to install grub on sdc... (Sata drive#3)...but the bios didn't know about this, and went back to sda (Sata drive#1). I had to try, but I'm not surprised it doesn't like to do that.


The system is seeing my RAID1 drives at SATA1 and SATA2 as individual drives. I recall seeing that in a post somewhere in my Google searches. I'm not sure how bad a problem this is at the moment. My goal at this point is to get the Mandriva installed on the 500G drive and booting, then I will be working with VirtualBox images for windows and mounting the content of one of the two RAID1 drives. So I'm not stuck on having RAID 1 imaging at the moment... it is just going to be too much of a hassle I think.


At this point, I can install Linux with the drive at it's current position, or move it to be SATA1 (or 0 depending on if you count from 1 or 0).


Since I'm lazy, at the moment, I'm thinking of letting the current install to the 500G drive complete (at address#3), and tell the installer to poke the boot image on SATA #1, if the system is really seeing these as individual drives... I don't know if the RAID controller will poke both RAID1 drives, but that is my guess. If I write to SATA1 the RAID controller will make both drives consistent. I'm not familiar with how the linux drivers get to the disks... could be they are bypassing the RAID controller BIOS layer... so it's possible I would get some RAID consistancy errors when the RAID controller sees different stuff at those sectors later. I'm curious to see what it does... of course I'm taking a risk that all the data on my drives could get wiped... so maybe I should just leave one of the mirrored drives unplugged... Hmmm. Perhaps both drives? Probably the safest bet...


This pass at installing was just to see if the pci-nommconf option made a difference. I did the boot without the pci=nommconf and just text mode, and it worked fine. So perhaps one more shot at installing with no options, just hitting return to see if I still get my original "sr" driver message.



Link to comment
Share on other sites

Interesting... I swapped my disks so that my JBOD (non RAID) 500G disk is at SATA0, and my RAID 1 drives at SATA1&2.

Then I attempted the Mandriva install with no options again... just to see if my "sr" message would return.


Generally it didn't work to well... I haven't been keeping copious notes, as I have work to do on my XP box involving making dlls out of libs in visual studio, and a customer bug on another matter... so I apologize...


But I did get a series of "martain source 255.255...." messages at one point. I broke for lunch, but I'm satisfied that I can still get the bad "it doesn't install" type issue if I simply load the Mandriva boot CD and do nothing and let it default to everything.


Selecting "Text" seems to be the solution. You have to be FAST and hit F3 right away, or you are toast... I think the timeout might be extended. If I select Text, I get a nice dialog based input.


More system details

I'm running a ATI RADEON HD4350 graphics card on a Ibox LCD display running from a DVI to VGA adapter on the video card. But generally display settings seem to work OK.

Although I see a lot of screen clearing going on, so it's hard to keep a log of what install problems may be occurring if you are trying to multi-task. But for any Neubies out there (and I could be one). I would highly recommend hitting F3 on the Distro CD to select Text mode, if you are having difficulty with the install.


I'm assuming that the big unique thing I have is that my primary disks are running through a RAID controller to the SATA port. (I've set RAID mode in the BIOS). The 500G drive is defaulting to JBOD mode, which is nice (I don't recall what the heck JBOD mode is, or if I spelled it correctly). At any rate the BIOS seems to understand that I want the drives 2&3 to be RAID mode, and drive1 to be normal non RAID mode (for now). This other assumptions I'm making are that the linux kernel & drivers are OK with this. When I had the order swapped, the installer saw the drives and the "custom format" tool let me partition my clean 500G drive. So generally it seems that all the drivers are hunky dory after the bootstrapping has completed.


I'm now going to do a third install with the 500G drive in the SATA1 (or 0 depending on how you like to count). And my RAID1 Array in SATA2&3. I'm pleasantly surprised that the RAID controller didn't mind that I moved the RAID1 array from SATA1&2 to SATA2&3... but I haven't attempted to check the integrity of this. Certainly a "trust but verify" thing. I never trust that anything that is supposed to work really does until I have verified it.... I only trust the important things that are supposed to work do, and when they don't of course I complain. Right now I don't care if the RAID array works so I'm surprised that nothing has complained about it so far to divert my attention.


Major Likes of this Distro so far are the "advanced" option for setting time via the internet via one of the time servers. This is great, and should be an option on all computers that can connect to the internet. Wish my VCR and my watch could do this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...