Jump to content

Screen resolution on laptop


Recommended Posts

I have had this issue with several generations of Mandriva in the past.

I install Mdv on my laptop, and the installation chooses the highest supported, "native" resolution of the monitor.

In my Lenovo laptop, this is 1920x1200 which is unusable.

The "native" resolution is the only widescreen format resolution it shows, the other choices are 4:3 resolutions.

The steps down should be 1680x1050, then 1440x900 which I use when running Windows.

I tried to get the Nvidia settings not to force the native res, but it gets ignored.

My Ubuntu installation on this computer uses the same Nvidia driver, but it allows me to change res to 1440x900.

Any ideas?

Thank you,


Link to comment
Share on other sites

Please explain why do you refer to 1920x1200 as "unusable" - does it work at all? Usually, under low resolutions the screen looks fuzzy, and you may want to think twice whether you really want to drop the resolution.


To switch to a lower resolution, I use the utility called xrandr - though I have an intel video card. If xrandr does not work for you, you may need to edit the Xwindow configuration file /etc/X11/xorg.conf. Please check the content of this file and locate lines similar to these


	# Monitor preferred modeline (60.1 Hz vsync, 55.7 kHz hsync, ratio 16/10)
ModeLine "1440x900" 102 1440 1488 1520 1832 900 903 909 926 -hsync -vsync

# modeline generated by gtf(1) [handled by XFdrake]
ModeLine "1440x900_60"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync


   Subsection "Display"
	Depth 24
   Virtual 1900 1200


In your case the preferred modeline will probably start with "1900x1200", but you need to have a lower resolution modelines such as "1440x900_60" in my example. Comment out the line that starts with "Virtual...", and add instead a line containing the desired modes, with the preferred mode listed first

		 Modes "1440x900_60" "1900x1200"

After restarting the X server (press Ctrl+Alt+Backspace, or simply reboot) you should be able to switch between modes by pressing Ctrl-Alt-+ and Ctrl-Alt--.

Link to comment
Share on other sites

Thank you very much for your decisive advise. Sorry I posted on two different forums, I am new here and realized after my first post that there was a specific laptop forum.

When I said "unusable" I should have said " resolution is so high that fonts are too small to read". The 1920x900 resolution works and is actually brilliant. Too bad I don't have good enough eye sight to enjoy it.

I will edit xorg.conf and I am now sure I can get it going.

Thanks again,


Link to comment
Share on other sites

As I was suspecting... In that case don't rush with editing xorg.conf. You just need to increase DPI (dots per inch) font setting, this will scale all fonts up but will keep them crisp. In GNOME, the DPI setting is found under Preferences-> Appeareance-> Fonts (or similar). In KDE 3.X the settings is in the KDE control center (kcontrol) -> Appearance & Themes -> Fonts. In theory, you can also change DPI settings by specifying DisplaySize in the Monitor section in xorg.conf, by starting xserver with the flag -dpi XXX (where XXX is the desired DPI setting), or by adding option "DPI" to the Device section of xorg.conf. I am saying this should work in theory, since I was unable to change the DPI settings on my T61 with Intel X3100. Apparently, the driver for intel cards takes care of this setting, and the fonts are auto-scaled. However since you have T61p and Nvidia, you may have more luck....


By the way, the GNOME method will work in Ubuntu as well, no need to switch to a lower resolution.

Link to comment
Share on other sites

Thanks again, Coverup. Yes, that works and the benefit is that the graphics, fonts etc. quality is uncompromised.

The downside is that even if you set the fonts in Firefox accordingly and not to take font sizes from html pages, many sites are authored so that they use their own font sizes no matter what. I can get around this using Ctrl + of course.

Also, you have adjust the fonts in Openoffice and GUI text editors.

The Nvidia kernel installation seems to somehow bypass the /etc/X11/xorg.conf file. It does not look like the one that is actually being used when Nvidia kernel is running. The Mode lines don't have anything that resembles the resolution being used.

There is a file /etc/X11/XvmCConfig which has just one line: libXvMCNVIDIA_dynamic.so.1

I have a feeling that that overrides xorg.conf but have investigate.


Link to comment
Share on other sites

I don't have /etc/X11/XvmCConfig on my box - I guess this is an NVIDIA specific file. Perhaps, a man page for Xorg and NVIDIA can shed some light on how to force the driver use other modes. As I mentioned, I use the command line utility called xrandr for this. Also, Mandriva Control Center used to have an option for manually changing and testing display resolution. Worth checking...


You are correct, many sites are authored in a way you mentioned. Just like you, I like crisp and big fonts and therefore have seen this problem many times. In many cases, the fix is to set a minimum fontsize in Firefox to say 18pt, though this may screw up the layout of some webpages. I however have a somewhat personal view ob this. You see, a properly designed webpage must meet certain accessibility standards including being accessible by sight impaired folks. If a web designer chose to ignore this requirement, they are in breach with equal opportunity laws the least. I am not suggesting each such designer should face a court over this, after all many of them simply are unaware of the problem because they have big screen displays and small brains. But you can complain or simply take your business elsewhere.

Link to comment
Share on other sites

I am getting a little bit of an idea what this is all about. I installed MDV2009 to a couple of other computers which also had Nvidia cards. The operating system installation prompts the screen resolution "automatic" and it goes easily unnoticed if you have ran through the MDV installations many times in the past.

If you don't accept the automatic, it hesitates for a while, then evetually offers manual options for the screen resolution. I chose one that I knew that the card and the monitor could do, but after the first reboot, the login prompt looked bad and X crashed after I had put username and passwd in.

So, I haven't tried this kind of installation yet with my good T61p, but the Mandriva people should take a look at this issue. The automatic is not a good option, a computer - any computer - may be installed with a low resolution for some purpose.

Thanks again,


Link to comment
Share on other sites

  • 2 weeks later...

I'll reply to my own question, but please see the discussion, Coverup had several good ideas.

It turns out that the akward thing about the Nvidia driver installation is that it overrides the traditionsl /etc/X11/xorg.conf settings.

The way I partitially got around the problem described in the original question was to:

- login into x as root

- run the NVIDIA Display Settings (as root)

- you seem to have more choices here than in the same program as a regular user

- I can set resolution here at 1680x1050 which is better than 1920x1200 and the settings will stick

- whatever changes you make here as a regular user, will not stick, you can't write to conf file

- however, those are the only usable widescreen settings, there is no 1440x900 like in Vista

- This must have something to do with the way the Nvidia kernel is programmed

- most likely not purpously setup the way it is

- this is a really bad thing, many laptops these days have very powerful video cards, but the highest resolutions are unusable

- hopefully this could be fixed in future updates ....

Thank you,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...