Jump to content

Openoffice wont start win MDK9.1

Guest DeathsFriend

Recommended Posts

Guest DeathsFriend

Hi All,

I've just done a fresh install of 9.1 Download edition, and no matter what I do, I can't get OpenOffice to run. I click on the icons in the menu, the OOo logo appears, and it sits on the task bar with a rotating hour glass for about 20 seconds, and then nothing. When I looked in my home directory, under .OpenOffice, and ran Setup, it was in a completely different language that I don't even reckonise.


Am I missing something here ? I can get OpenOffice without problems on my other MDK9.0 machine, so what changed ?


Thanks Guys.


Link to comment
Share on other sites

hmmmm........what desktop/window manager are you using? i've heard of similar OOo problems with people that are using Gnome/sawfish. if you're using one of those, let me know & i'll give you the work around.




shit........here's the answer if the above does pertain to you. no sense in waiting, huh?



On trying to start OOo, the splash screen appears, and, depending on the

speed of your machine and the --purge-delay option to gnome-session, a

window may appear briefly, but then it closes. For certain machines,

opening a document and pressing keys in it before it closes will keep it

up, too.


Workaround: simply




before starting openoffice. You can also workaround the problem by

increasing the --purge-delay parameter to gnome-session.



Link to comment
Share on other sites

okay then........


did you install OOo from rpm or tar? if it was tar, maybe try installing via rpm instead. also, have you tried running it from terminal? by doing it that way, you should be able to see some errors that might help pin point why it's bombing. to do so in KDE:


open Konsole->


cd to your OpenOffice/program directory (mine is in usr/lib) so:


cd /usr/lib/openoffice/program


type soffice


that will start (or try to) OpenOffice. post the error(s) you get in Konsole here. maybe i (or someone else) can figure it out with that info.





when you install MDK, OpenOffice should be installed by default, unless for some reason you didn't select that package. so, there's no need to run "setup". also, the OpenOffice folder in your /home directory is linked to the main install in /usr/lib. the folder in your home directory just contains user specific settings for the main OOo program.



Link to comment
Share on other sites

Guest DeathsFriend

The strange thing is, the copy of OO this is installed on the machine, was installed by Mandrake when I installed the rest of the system - it just never worked.

I managed to fix it, however, by removing the default rpm's and downloading a new version of www.openoffice.org and installing that from tar... works like a charm!!! Now if I can only remember where I saw that "quick start" for it, I'm laughing..... Bye, Bye Microsoft.....


Cheers for the help,


Link to comment
Share on other sites

Guest earp_james

I too have the same problem...so dont feel alone


Think I'll just install 1.1Rc version from a tarball....


As you say goodbye Microsoft....


Mandrake 9i installs lovely in every other respect and the whole pallet of apps you get is fantastic.. makes me feel like going and helping on an Open source Project....but which one ...



Link to comment
Share on other sites

Guest DeathsFriend

Looks like I'm not alone!!!


I've had a few difficulties moving over to Linux, not least with configuring hardware (sound card mainly, but I got working in the end by myself!!). The only thing left for me to do now is customise my system with my own themes, etc.... The only thinging I'm finding difficult is the Bootsplash screen....


I too installed from the 1.1RC tarball, and it work's flawlessly. I'm still searching for ways to speed up it's startup, but we shall see...


As for helping out a project - I intend to get my hands dirty after I've got to grips with Linux Programming - I'm a software engineer by trade, and I hope to be able to use my skills to return something to the community.


See you all out there...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...