Jump to content

2009.0 on Itronix IX260+ [solved]


Recommended Posts

Recently picked up an Itronix Gobook 3 (IX260+) rugged laptop off ebay.

Was considering getting a Netbook of some flavor, but realized that for my needs, something more or less indestructable could be handy,

and having a "normal" screen resolution and real HD/CD etc was a nice bonus.


In any case...


Basic specs:

12.1" screen

Pentium "M" 1.8GHz, "Dothan" 2MB cache

(now has) 2GB PC2700 (DDR) memory (max 2G)

40G HD (Rugged IBM laptop drive, in shock mount cage)


1x USB2 (bootable)

FW400 (Probably bootable) has the mini connector

2x cardbus slots (external) 1 internal

1X miniPCI (the wireless card currently lives here)

Optional touchscreen (works great under XP)

Optional GPS (internal, lives on ttyS3 on mine)

Optional wireless a/b/g (Internal, Mine was Intel PRO 2200 b/g)

Optional cellular modem (Not on this one, would live under the CDROM, extra internal cardbus connector)

Optional Bluetooth (internal, mine not so equipped, would live next to the GPS card in the lid)


Rated for repeated 3' drops onto concrete, water spray from any angle, and many other creative forms of abuse.

Not only could you use it on the toilet, you could use it in the shower if so inclined...


It weighs nearly 9 pounds, due to it's mostly cast magnesium construction.

Do not drop test on your foot.



(HD came wiped)

Put 2009.0 KDE international CD



Got to X and .. mouse moved spastically for awhile and machine quickly became unresponsive.


As this is not my first rodeo, power cycled, and added "3" to the kernel command line, brining it up WITHOUT X11,

also set fb to 1024x768 usung the F3 hotkey in the installer (f4 to get the kernel command line up.


allowed it to boot again...


Ran XFdrake from the console, and turned off 3D accell and HW mouse

(HW mouse later turned back on, 3D was the issue)


typed "telinit 5" and it came right up in all the glory KDE4 can manage, which is actually pretty decent.


Install from the live install ran fine, was able to configure the Intel B/G wireless either before or after install, (the settings get loaded into the fresh install) and the machine works VERY nicely, with only minor issues...

(The other (optional) wireless that might come with a gobook 3 would be an Atheros unit, which would also be handled out of the box)


1) The Semtech touchscreen is nonfunctional, supposedly the evtouch X11 driver can deal with this, haven't gotten that far yet.

There IS a Semtech kernel driver specifically for this laptop in the wild somewhere, but all the links are dead.

(It is actually worse than nonfunctional-- It you try to use it, (works with a stylus) the data IS getting to the mouse driver (psaux device), and it usually renders the kbd/synaptics mouse inop, causing a need to power cycle)



2) 3D still does not work.

Using "ati" driver, current fglrx versions do not handle this old ATI R250 card.


Annoyingly, I was playing with some xorg.conf files, got 3D working fine, managed to get fragged a few times playing Alien Arena 7.20 on low settings at a reasonable framerate (a REAL mouse is required for FPS use)...

...Saved the "working" xorg.conf, and powered off for the night... Wouldn't work again this morning using that xorg.conf.


The issue is loading "dri" --- causes the same symptoms seen initially, X11 slows to a crawl with a jerky mouse and eventually hangs completely.


EDIT--- 2007.1 and 2008.0 ONE works flawlessly as far as 3D accel goes, using the old fglrx driver of the day.

Sadly fglrx no longer supports the R250, and the ati driver seems to have some issues...


2008.0 is going on... The amusing thing is not only is it sucessfully using the "ati" driver (with working 3D) but evdev loaded as it "found" the touchscreen...

Edited by waferhead
Link to comment
Share on other sites

It really didn't say anything of interest... but after my 4th 2009.0 install+updates this afternoon(using the same disk and technique)

dri now works with the ati driver.

Did the same a few days ago and last ran updates/tried it before posting a bug report... Oh well. :wall:


The bug report and workaround still valid for the install.


I'm wondering if bits of fglrx were floating around in the previous install(s), there are apparently known conficts between fglrx and ati driver installs and dri.

I DID tell it to remove unused drivers this time around, based on that Google provided info...


Interesting thing.. The XFdrake generated xorg.conf no longer contains the final stanza it did yesterday:

(Today, generated by rev 247269, I sadly nuked the old files from orbit)


Section "DRI"

Mode 0666


Section "Extenstions"

Option "Composite" "Enable"



Thought I had an "Aha!" moment, but It doesn't seem to matter if it's there or not, I added it in manually, still works. Hmph.

Odd... 3d accel for normal users SHOULDN'T work without that "Mode 0666" , but it does, now. :speechless:

Link to comment
Share on other sites

Truly bizzare-- the issue is back, no explanation.

The only things I have done is load the qt3/4 and kernel//misc devel stuff, still running the same kernels. both of which worked.


I unplugged a USB hub, then X immediately locked up with a colored snow crash.

Rebooted and I'm back to the original issue, even tried booting into XP and then back into Linux to see if it was some register getting reset-- No help.


Tried commenting out the above section in xorg.conf to no avail.

Only "Disable "dri"" helps.


I'm starting to wonder if it's heat related... Will stuff the laptop in the fridge for awhile to test.

(It's a Gobook, it will deal with that fine)

Link to comment
Share on other sites

OK, not thermal, dug into the xorg logs more closely and it's apparently a incarnation of:


and the other ones with the xserver going into an infinite loop, traced to a bug in the kernel drm module.

(One variant is in the 2009.0 errata)


The smoking gun is in /var/log/Xorg.log.old (in this case)

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

[mi] EQ overflowing. The server is probably stuck in an infinite loop.



It just only seems to be triggered on this system when dri is loaded, which makes sense.


Starting in non-fb mode (Per the errata) does NOT seem to be a work around for me.


Will try some earlier/later vanilla kernels, since it's being blamed on the kernel.

Link to comment
Share on other sites

  • 2 weeks later...

Moving over to cooker yesterday resolved the 3D issue, apparently fixed by the new Xorg.

There were no notable issues upgrading, surprisingly.

(Simply aimed urpmi at the cooker repo using easy urpmi and did "urpmi --auto-update")


Compiz/Metisse have issues, but OpenGL games run, and X11 doesn't simply hang when 3D is selected.

Kwindodecorator repeatedly crashes under Compiz, selecting Metisse results in X11 failing to start and ending up back at kdm login.

One has to turn off 3D support to log back in and turn off Metisse.

(I suspect some missing OpenGL call support)

Link to comment
Share on other sites

  • 4 weeks later...

wafer, only slightly off topic, if you dont mind, what did you pay for that?


the reason I ask is that I bought an itronix for a similar project (different model, but dont remember it off the top of my head), anyway i knew it didnt come w/ a PS but I figured I'd buy one later.


the PS is 2x what I paid for the device!


Just wondering if they have gotten anymore reasonable. I worked with them in the 90's at a GOV Contractors and liked their ruggedness.


but they DO use a LOT of proprietary HW.


(we wrote our own OS)



Link to comment
Share on other sites

  • 5 months later...

Sorry, just noticed the follow up post.

I paid $220 for it from Dealtree, off ebay. Came with a vehicle dock too.

Machine is quite solid except for the unfortunate need to turn off 3D.


It's almost amusing that 3D is inop on this chipset, as it was one of the first chipsets with 3D support on Linux. Sadly it seems to have been broken since early 2008.

Link to comment
Share on other sites

  • 6 months later...

Follow up:


I later came across the trick--- add


Option "AGPMode" "1"


to the "device" section of xorg.conf, and turn 3d on by changing the line in "Module" to say


Load "dri"


The IX260s chipset or graphics board horks on anything but mode 1 AGP.


xv works nice, plays DVD or streaming scaled HD in mythtv fine.

Link to comment
Share on other sites

  • 3 weeks later...
Guest jimclarson

hi, i have the same exact laptop as you and am using Linux with dri and the open source radeon driver being used, and my card is an radeon RV250 [ati mobility firegl 9000]


i was wondering if I could have a copy of your config file? it would be much appreciated ^-^

Link to comment
Share on other sites

  • 9 months later...
  • 9 months later...

It's baaaaack, under Mageia as well.


Just assume you need to start up from the boot CD in runlevel 3 as described above.


Also helps to set speedboot=no and clocksource=jiffies in the kernel command line (set in grub config)

The latter "fixes" seem to stop weirdness on many machines, should probably be default.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...