Jump to content

Dual Boot Issues


Recommended Posts

I've been using Mandriva for a few years now, and decided I finally need to bite the bullet and dual boot with XP, as uni requires me to use some win stuff that runs horridly under wine.


So, a fresh XP install went fine, using only a small part of the drive (really only need web browsing with IE and shockwave/flash etc), and then I booted with Mandriva 2008.1 live cd and installed - all went ok. When I go to boot to windows it gives me the bl**dy bloo screen. I start remembering why I stopped using it in the first place! (I could boot to windows fine before mandriva went on).


Error being STOP! 0x0000007B. Blah blah blah, damaged disc etc. Can boot to mandriva perfectly fine, just not windows.


Windows part of boot menu reads (i'm using grub):


title windows
rootnoverify (hd0,0)
chainloader +1


fdisk -l


Device Boot	  Start		 End	  Blocks   Id  System
/dev/sda1   *		   1		1355	10243768+   7  HPFS/NTFS
/dev/sda2			1356	   41345   302324400	5  Extended
/dev/sda5			1356		2438	 8187448+  83  Linux
/dev/sda6			2439		2979	 4089928+  82  Linux swap / Solaris
/dev/sda7			2980	   41345   290046928+  83  Linux


Can anyone assist with my annoying problem? Suggest a cure, or something I've done wrong? Looking up the windows troubleshooting with the error code proved pointless, and I've re-installed both twice now, so it wasn't just a one off problem. At the moment I've got XP only on there, and am using mandriva 2008.1 from the live cd, have not done installation again yet in case there is something I can do beforehand that will make it all work properly!



Link to comment
Share on other sites

Does it help to add a line


after the "rootnoverify" one?

Normally it shouldn't be needed, as this disk has just one primary partition, but you never know with windows...

You could also try booting windows in safe mode and see if it stops complaining (it might be just a driver from a third party app which thinks the disk is damaged, and it may not be loaded at safe mode).

Plus that some things that do not run well under wine run fine under VirtualBox or VMWare, and vice versa.

Link to comment
Share on other sites

Not sure if it's gonna help but I just had a very similar problem which arose as Mandriva helpfully graunched my disk 1 partition table during install.


I got a lot of helpful advice from others (see Dual Boot on Two Drives) in this section. Grub needs a "mount point" for the XP partition after which it worked fine for me. The hard bits I found was a) understanding what that was about, and then b) restoring the lost partitions, and then c) allocating the mount point.


But eventually it worked out.



Link to comment
Share on other sites

Grub needs a "mount point" for the XP partition after which it worked fine for me.

No, it definitely doesn't.

Grub does not care at all about mount points or the fstab entries. It uses its own nomenclature, and (hd0,0) as used it just fine... for that particular case, it is.

Edited by scarecrow
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...