Jump to content
Roberto Oropeza

Can't boot because I uninstalled (all) fonts

Recommended Posts

Yap, I uninstalled every font from my system, and now I cant start the graphic server, it complains about missing FIXED font, and lets me in text mode. ¿How do I install it again from the command line? (I know my root password) ¿In which package file is it?

 

Help me please!

Edited by Roberto Oropeza

Share this post


Link to post
Share on other sites

I ran urpmi task-X11 and it said that that package is already installed.

 

I've saw the advice David Batson posted and seems a little complicated, or at leas not as easy as installing something, I'd like something like urpmi something else; I just uninstalled something that was in my DVD so I should be able to recover it in some easy (but command line) way, may be someone knows which is that default 'fixed' font that X11 can't find and in which package it is.

 

Anyway, I'll try the David Batson way right now. But hope there is a easier solution. Keep helping, please.

Share this post


Link to post
Share on other sites

Ok, the X graphic servers complains because can't find default font 'fixed', and also said it uses /etc/X11/xorg.conf configuration file, so I read that file, and checked its man page, and discovered that it searches fonts in the directories that FilePath specifies, but my xorg.conf file doesn't have any FilePath, so, as the man page says, it should be looking fonts in

 

/usr/lib/X11/fonts/misc ,

/usr/lib/X11/fonts/TTF ,

/usr/lib/X11/fonts/Type1 ,

/usr/lib/X11/fonts/75dpi

/usr/lib/X11/fonts/100dpi

 

but, surprise, I don't have the /usr/lib/x11/fonts directory (nor its subdirectories) so I guess this is the reason why it can't find the 'fixed' default font.

 

Can anyone check its /etc/X11/xorg.conf file and check if it does have any FilePath specification and, if it doesn't, do you have the /usr/lib/X11/fonts directory and its subdirectories?

 

Should I create those directories and put some symlinks or files there? HELP PLEASE.

Share this post


Link to post
Share on other sites

Yes, I did run XFdrake, it ran in text-mode and I disabled Composite just to test if it makes it better, reviewed the settings (graphic card, resolution, refresh rate) and everything seems ok.

When I went to Test it didn't say anything and went back to the main XFdrake text dialog (I think the test didn't succeed).

 

By the way the complain message is: can't find the default font 'fixed', and I uninstalled and reinstalled the fonts, so IMHO the problem should be there...

Edited by Roberto Oropeza

Share this post


Link to post
Share on other sites

I didn't delete any file directly.

 

I uninstalled all the fonts from the "Fonts and Windows import wizard" tool of "Configure my Computer" tool. When I quit the "Configure my computer" I couldn't start the "Install and remove software" tool, (it just didn't started, without even an error message), fortunately the krusader twin-pane file manager did work, althougth with a rare ugly font, from that I went to my 2008.0 DVD and from the /media/main... directory (I can't remember the exact path) installed everything that had a font relative file name (i.e. *font*.*) with the "Install software" tool. (I don't remember if it asked my root password), I restarted krusader and it worked fine, with its habitual font, restarted my computer and... I saw that error message.

Share this post


Link to post
Share on other sites

IIRC, I reinstalled the fonts from the DVD. Use your DVD for the medium, search and make sure the following is installed:

1) libfreetype6 (might also need freetype and freetype-tools)

2) libcairo2

3) libxft2

 

Depending upon what you did, you may want some other font packages as well.

 

EDIT: I just remembered you are using the command line. See the following: http://wiki.mandriva.com/en/Tools/urpmi

Edited by David Batson

Share this post


Link to post
Share on other sites
I didn't delete any file directly.

 

I uninstalled all the fonts from the "Fonts and Windows import wizard" tool of "Configure my Computer" tool. When I quit the "Configure my computer" I couldn't start the "Install and remove software" tool, (it just didn't started, without even an error message), fortunately the krusader twin-pane file manager did work, althougth with a rare ugly font, from that I went to my 2008.0 DVD and from the /media/main... directory (I can't remember the exact path) installed everything that had a font relative file name (i.e. *font*.*) with the "Install software" tool. (I don't remember if it asked my root password), I restarted krusader and it worked fine, with its habitual font, restarted my computer and... I saw that error message.

that actually deletes the fonts, not uninstalls them

 

try

rpm --all-matches --nodeps x11-font && rpm -e task-x11 && urpmi task-x11

Edited by ffi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...