Jump to content

Gentoo Nut UPS [solved]

Recommended Posts

  • Replies 36
  • Created
  • Last Reply

Top Posters In This Topic

Well Mysti I feel like I am the person responsible for getting you to try NUT. So I will tell you all I know about the subject. OK, so maybe that is not so impressive but here goes... :lol2: Maybe something here will be of help.


In addition to the obvious differences between your situation (Gentoo) and my situation (Mandriva), my UPS communicates via a serial cable. If I am not mistaken, your UPS uses USB.


On my Mandriva 2005 box I installed The Network UPS Tools (NUT) version 2.0.1




In /etc/ups the following files were manually edited:





in ups.conf the following was added:


driver = apcsmart

port = /dev/ttyS0

cable = 940-0024C


in upsd.users the following was added:

# Supervision user


password = mypass

allowfrom = localhost

actions = SET

instcmds = ALL


# Protection user


password = mypass

allowfrom = localhost

upsmon master


in upsmon.conf the following was added:

MONITOR myups@localhost 1 monuser mypass master


documentation can be found in: /usr/share/doc

the status of the ups can be checked with: upsc myups@localhost

Link to comment
Share on other sites

Thanks, well it's finding the drivers now and everything wants to work except I must be using the wrong portm it the only other thing that I can figure because it can't communicate with it. I'm using the same port as you are, not usb, because I googled and that's what port it told me to use. So I guess my next step is to try other ports. All 50+ something of them! :o

Unless somebody has a better idea of how to figure out what port it's using? I know tty0 - tty5 are being used by other processes because I saw it when I ran ps aux.

Link to comment
Share on other sites

I tried that once but I'll try it again. The only other thing I noticed is that he has a cable type and I don't. But I have no idea what kind of cable this is except a serial cable. Any idea what number that would be?

Link to comment
Share on other sites

auto only works for usb. And unfortunately I can't use usb because I have no drivers. I contacted intel and the only ones they have for linux are suse and redhat. Won't work for me.

Link to comment
Share on other sites

I used the following to identify my serial controller:

cat /proc/pci


Look for "serial controller" and find the IRQ and IO ports. Then use the setserial command to set up the serial port. For example, to setup com 2:

setserial /dev/ttyS1 irq 10 port 0xa400


Make sure your serial ports are activated in your BIOS too.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...