Jump to content
studmuffin007

MCC [solved]

Recommended Posts

Thanks for the reply Floyd i looked to see if

/usr/lib/libDrakX/ugtk2.pm

/usr/lib/libDrakX/mygtk2.pm

were there and they are so i did urpme drakxtools

 

then # urpmi drakxtools and this is what it returned

 

The following package cannot be installed because it depends on packages

that are older than the installed ones:

drakxtools-newt-10.4.81-1mdv2007.0

drakxtools-10.4.81-1mdv2007.0

Continue installation anyway? (Y/n) y

The following packages have to be removed for others to be upgraded:

libdrakx-net-0.12-1mdv2007.1.noarch

(due to conflicts with drakxtools-backend[<= 10.4.83]) (y/N) y

Packages drakxtools-10.4.81-1mdv2007.0.i586 can not be installed

 

Thanks

Share this post


Link to post
Share on other sites

The following packages have to be removed for others to be upgraded:
libdrakx-net-0.12-1mdv2007.1.noarch
(due to conflicts with drakxtools-backend[<= 10.4.83]) (y/N) y
Packages drakxtools-10.4.81-1mdv2007.0.i586 can not be installed

It appears you have version conflicts. Urpmi is attempting to install package from 2007.0 however you have packages from 2007.1 installed.

What version(s) were you using? or currently using?

 

 

studmuffin007 post Apr 29 2007, 04:47 PM Post #3

the entry to update is missing

(one of main_release, contrib_release, non-free_release, main_updates, contrib_updates, non-free_updates, main_backports, contrib_backports, non-free_backports, main_testing, contrib_testing, non-free_testing)

Whats that mean?

One thing it appears to mean is that you had testing repos configured.

 

Packages drakxtools-10.4.81-1mdv2007.0.i586 can not be installed

I t appears you are trying to fix mcc from version 2007.1 by using rpms from version 2007.0.

I would suggest removing the repos pointing to version 2007.0 then set your repos to 2007.1.

http://www.mandrivausers.org/easyurpmi/index.php

If you had packages installed from (main_testing) "cooker?" and I am not implying you did, then problems like these are expected.

Isn't "main_testing" a repo for cooker?

Share this post


Link to post
Share on other sites

Thanks for that floyd as far as i know i have 2007 spring free version, i have even tried to update it using powerpack 2007 spring hoping that would help but all it did was change the boot screen to a black 1 with a green box and a few choices to boot from,

 

Linux

Linux-nofb

2.6.17-5

linux-enterprise

enterptise 2.6.17-13

alt_linux-enterprise

failsafe

 

if i copy and paste the output of easy urpmi into console will that over write the old ones? if not how can i remove the old ones.

 

Thanks in advance

Share this post


Link to post
Share on other sites
if i copy and paste the output of easy urpmi into console will that over write the old ones? if not how can i remove the old ones.

urpmi.removemedia -a

Share this post


Link to post
Share on other sites

I reinstalled drakxtools, and it seems that it solved the problem with wireless, but because of dependencies lots of other packages were removed.

I'm reinstalling them now.

Share this post


Link to post
Share on other sites
Maybe checking if you have these files or reinstalling of drakxtools will help.

Here is a link with similar symptoms to yours.

http://www.linuxquestions.org/questions/sh...ad.php?t=527362

 

 

I am also in similar trouble: software installer exits unexpectedly after a failes smart-urpmi upgrade

 

it is today the third day of desperation looking for a solution

 

:wall: root@smitdesk dr_smit]# rpmdrake

Can't locate auto/urpm/configure.al in @INC (@INC contains: /usr/lib/libDrakX /usr/lib/perl5/5.8.8/i386-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i386-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.7/i386-linux /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl .) at /usr/sbin/rpmdrake line 1507

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...