Jump to content

Truecrypt on 2007.1


Recommended Posts

I never had a problem compiling or running Truecrypt 4.2a on 2006.


On 2007.1, I got the following error trying to mount a truecrypt volume after compiling it:


insmod: error inserting '/usr/share/truecrypt/kernel/truecrypt-2.6.17.ko': -1 Invalid module format
FATAL: Error inserting truecrypt (/lib/modules/2.6.17-13mdv/extra/truecrypt.ko): Invalid module format
truecrypt: Failed to load TrueCrypt kernel module


Based on a tip from a post in the Club forum, I forced the module load with the following command:


modprobe -f truecrypt


After that, it worked. The man page says that the -f option tries "to strip any versioning information from the module, which might otherwise stop it from loading." So the -f option must be stripping out something from the truecrypt kernel module that is causing the above error.


Now, for the latest Truecrypt version 4.3 - if it compiles at all, it apparently takes a really long, long time to compile. The Club forum post mentioned that. On my machine, Truecrypt 4.2a compiles in about 5 seconds. I tried to compile version 4.3 and after at least 10 minutes, it still hadn't finished. I got no error messages. So I killed the process. Either it's getting hung up or else it's taking an amazingly long term to compile compared to version 4.2a.


Has anyone else got a successful compile of Truecrypt 4.3? If so, what was your experience? Did you need to do a modprobe -f to get an encrypted volume mounted or created?

Link to comment
Share on other sites

There has just been too many kernel problems with truecrypt and the devs don't seem to welcome any input from the larger OSS community, at least that's what I've been reading on some debian boards. As a result, I've started using cryptsetup with LUKS as outlined in this article:




This has native linux kernel support and I've run into far fewer problems with it. It's worked fine on mandriva since 2005, pclos, kanotix/sidux. Had some trouble with slackware but that was probably due to not having the necessary kernel modules compiled in my custom 2.6 kernel. Check out this wiki for more on supported distros:




Also, recent versions of FreeOTFE for windows appear to support linux created LUKS encryption although I haven't tried this myself:



Link to comment
Share on other sites

pmpatrick - thanks for the info. I will look into the apps you suggested. I need to have both Windows and Linux support of the same encrypted files so that's good that LUKS may have Windows support.


Here's an update on building and running Truecrypt 4.3 on Mandriva 2007.1. I got a successful build today from source code. It took 54 MINUTES! The build was done in the foreground, not as a background process. I needed to execute the 'modprobe -f truecrypt' command to get the kernel module loaded.


Yesterday I mentioned that a Truecrypt 4.2a build took about 5 SECONDS!


So if you're building Truecrypt 4.3, let it run and go watch a movie!


EDIT: I'm running the standard 2007.1 kernel- with the corresponding kernel-source.


/var/log/messages contained the following message.


truecrypt: no version magic, tainting kernel.


Perhaps that was why the modprobe -f was needed?

Edited by jboy
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...