Jump to content
Sign in to follow this  
Guest TobyF

Newbie trying to install 2007 - graphics [solved]

Recommended Posts

Guest TobyF

Hi Mandriva Users,

 

I'm a complete linux newbie trying to learn the OS by setting up a dual boot XP/ Mandriva 2007 system.

 

I have an eVGA 7800GT video card. When I tried the PC Linux OS and Ubuntu Dapper Drake live CDs, I always had to boot them in 'safe graphics' mode.

 

When I went to install Mandriva, I got as far as the Configuration screen, and clicked on the graphics option. It had recognised my video card and 19" NEC CRT with no problems, and selected a 1280x1024 24-bit desktop. When I clicked on the 'Test' button, though, I got a blank grey screen with a mouse cursor, and could not find any way of escaping the screen. I eventually hit reboot, which meant my installation was incomplete.

 

It has installed LILO perfectly, and I can still boot into XP with no problems (thankfully). I would now like to retry the installation, and am hoping for a little bit of help.

 

1) Firstly, if anyone can explain why linux may not overly like my video card, and what are the best steps to take about this (remembering I haven't ever used linux before, save for messing around with live CDs), it would be grealty appreciated,

 

2) and secondly, will re-starting the install risk messing up LILO?

 

Many thanks.

 

Sorry, perhaps I should have also mentioned that I am installing the free 32-bit version (though on an AMD X2 4500+) from the all-in-one DVD.

Share this post


Link to post
Share on other sites

I would suggest what you do when configuring your screen is to configure it as VESA during install. That way, you get a basic graphics, you can finish the install, and then work at configuring the screen properly once you've got a full install.

 

That way, if the screen doesn't work after install, you can just drop to a console and reconfigure it from there.

 

And no, shouldn't screw lilo. I've swapped between lilo and then grub, and back to lilo again and never had a problem.

Share this post


Link to post
Share on other sites
Guest TobyF

Thanks greatly ianw1974,

 

I reinstalled and selected the VESA driver.

 

The good news is LILO is fine.

 

The bad news is Mandrake boots to a screen which flicks between black and blue forever and never brings up the desktop (in both normal boot and nonfb - which I don't know what it stands for). No error messages (though I wasn't in verbose mode for the normal boot). The failsafe mode dumps me in command prompt with no problems.

 

The install was selecting my video card as just 'Geforce 7 series', and it looks like the eVGA isn't in its database like the other big video card brands.

 

Any help much appreciated.

Share this post


Link to post
Share on other sites

From the command prompt, try entering:

mcc

which gets you to the mandriva control centre. From there you can try different resolutions, different monitors, etc. etc. Hope that helps...

cheers,

Helmut

Share this post


Link to post
Share on other sites
Guest TobyF

Thanks Helmut, on a recommendation I tried PCLinuxOS (Mandriva based) and that worked like a charm. Entered it in a safe graphics mode and then installed the lateset nVidia drivers and everything is OK.

 

Thanks,

TobyF.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...