Jump to content
Alistair

Mandriva Free 2007 hangs on reboot after HAL

Recommended Posts

Why do you want to bother installing mandy one when you have mandy 2007 working?

 

You could go with the former comment below

and once in text mode, type su to be root

then drakx11 to (re)configure the video card

The X server loads right after ALSA; my guess is you have misconfigured your matrox graphics card and that is what is hanging up your boot. You also appear to need those boot parameters to get that far. To test the theory, we can try booting in nongraphical mode so the X server never tries to load. Pass the following boot parameters:

 

linux noapic nolapic acpi=off nopinit 3

 

Mandriva One is supposed to work in Live Mode.

The one I have is Not.

It's not a matter of getting to an X environment, it's not getting that far into boot.. It's not getting past the HAL Daemon.

 

AND, I want to get this working so that I can have my favorite Linux Flavor as a demonstration for a die hard Microsofter, especially after he has cast aspersions on the efficacy of Linux due to "the driver issues he's heard about".

Plus, I haven't bought a Mandy edition since 10(PowerPack). It's about time to do so again and I want to be certain that all is well before I send my money off.

 

So, if no one else is having this problem I'll bid you all a good day.

Share this post


Link to post
Share on other sites
Guest sharke
I'm guessing you have LILO installed instead of grub which is why John's suggestion isn't working for you.

Grub all the way ;-)

 

Using the rescue mode of the install cd, it should be

a breeze to replace lilo by grub

Alister

Boot failsafe at the sh promt enetr login enter username enter password enter startx.

This should get you to a graphical desktop if so pressAlt 2 on the keyboard this should open a console.

Enter su in console enter root password enter kate /etc/lilo.conf this should give you the config file you are wanting to edit.

Regards

Sharke

Share this post


Link to post
Share on other sites
Guest dan1600

Hi All

 

just thought i out my 2c worth in. im using the 2007 one livedisk

 

I as having the same problem in that it would just hang after starting HAL daemon

 

heres what i went through

 

i downloaded the image burn to disk (using windows 2000 server and nero 6) using my server - and it hung just after Hal daemon on my server laptop and work comp

 

thought it might be a bad image download so downloaded again tried the above again on all 3 comps- again hung just after hal daemon

 

thought that after downloading the image twice it would be ok so ruled that out. then considered that my dvd burner on my server could (and i think is) having issues so i transfered the image to my laptop (via my wireless network) and burnt to disk using my laptop dvd drive. - still no good on all 3 comps and hung just after hal daemon

 

thought id give it one final go and transfered the image again to my laptop (knowing that my lappy has the best optical drive i own) this time using my proper LAN (being via my cat6 crossover network cable) and burnt it using (my lappy runs windows xp) nero 7. however this time i dropped the speed to as low as i could go (being 8x on my lappy) after the burn i shut down my lappy and rebooted and presto it loaded perfectly. i then took it to work and no probs again on my work pc

 

Alistair have you tried burning the disk at as lower speed as you have available? and with a dvd burner you know is working perfectly?

Share this post


Link to post
Share on other sites

Thank you dan1600.

That's what I was trying to get at in this thread and, please don't anybody don't take this wrong, this is not a bitch gripe, but nobody was listening to me. :wall:

I haven't had time to burn another DVD as yet but I'm now sure that's the problem. I'm in the middle of setting up another box for my wife and she's already convinced that veesta is not for her; so I've convinced her that a dual boot with a 64 X2 may be a better way to go.

 

Again, my thanks.

Share this post


Link to post
Share on other sites

Just a quick update.

I downloaded new images of One, One-Matisse and OneKDE (different server). Turned my burner as low as it will go. Defaults to 10X and, BEFORE ANYONE ASSUMES ANYTHING, this is the same burner that has burned Ubuntu, Kubuntu, FedoraCore6, SBELive, LinuxXP, 3 versions of Knoppix, 2007Free which just recently partitioned, installed then rescued grub (after the XP install) of my wife's AM2 upgrade and have made copies of various DVDs with no problems.

 

I DON'T THINK IT'S THE BURNER!!!

 

AND, from seeing some of the other threads here this is not a single occurence.

 

IF Mandriva wants to stay out front, and I do wish them to with all my heart, this problem needs to get fixed AS SOON AS POSSIBLE! I don't have the education or the apptitude to debug the code or even to analyze the boot record.

 

In the scenario I have, there is no boot record.

 

The Mandriva disks will not operate live. Everyone elses will.

 

Goodbye

Edited by Lagrosse

Share this post


Link to post
Share on other sites
Guest Doctor Toffú

Hi ^_^

This thread is quite old but just in case anyone still is having this hang, I had the same problem in my old computer and figured it out a solution to complete the booting process. Although loosing the HAL functionality, but it doesn't bother too much...you'll just have to mount your cdrom's and pendrives the old way. Anyway, the simplest way to avoid the freeze is to go into /etc/rc.d/rc5.d/ and delete the symlink whose name includes the infamous HAL (I don't remember exactly but is something like S99HAL...). This way the init system won't try to load the HAL Daemon in the runlevel 5 (graphical). If you want tho avoid the issue in the other runlevels just delete the same symlink in the respective folder (rc1.d, rc2.d, rc3.d, rc4.d) Remember that the runlevels 0 and 6 are shutdown and reboot so you don't delete anything there. The problem seems to happen on PC's with Pentium III or alike, which wasn't fully ACPI compliant.

 

Good luck. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...