Jump to content

LinDVD Drive Assignment


Recommended Posts

Hi all,


I've just installed the discovery version of Mandriva 2007 that includes the commercial packages including LinDVD. I've seen the posts where people are claiming it is working right out of the box (so to speak).


However, for me, LinDVD appears to have incorrectly assigned my DVD drive.


In my fstab my DVD burner (hdc) is mounted at /mnt/dvd and my cdrom burner (hdd) is mounted at /mnt/cdrom


However, LinDVD indicates that it is trying to use /mnt/cdrom (it may even say cdrom2 as I can't see all the words). Unlike what I would expect from a linux program, I can't find any file or option to change this. The only directory in my /home directory for LinDVD has a directory tree that looks like a Windows reg file.


Any suggestions?




AMD 2800xp

Asus A7N8X

Nvidia GF4 mx440

1x Max 160 gig

1x WD 120 gig

1024 gb ddr

Link to comment
Share on other sites

Please post your fstab file and the exact error message. If LinDVD is looking at /mnt/cdrom2 and there is no way to alter this behavior, you can always create a symbolic link to /mnt/dvd by running the following as root:


# ln -s /mnt/dvd /mnt/cdrom2


However, all the other dvd players I've used want the device file for the dvd drive(/dev/dvd), not the mount point. /dev/dvd is just another symbolic link to the real device file, in your case /dev/hdc. You can usually create the needed links in /dev to get around these types of problems if that's what's going on but you need to get the error messages to be sure.

Link to comment
Share on other sites

Here is my fstab:


[18:23:56][andrew@solitaire][~]$ cat /etc/fstab

/dev/hdb5 / ext3 defaults 1 1

/dev/hdb7 /home ext3 defaults 1 2

/dev/hdb2 /mnt/backup vfat umask=0,iocharset=utf8 0 0

/dev/hdd /mnt/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0

/dev/hda5 /mnt/download vfat umask=0,iocharset=utf8 0 0

/dev/hdc /mnt/dvd auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0

none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=utf8,sync 0 0

/dev/hdb1 /mnt/shared vfat umask=0,iocharset=utf8 0 0

/dev/hda1 /mnt/win_c ntfs umask=0,nls=utf8,ro 0 0

none /proc proc defaults 0 0

/dev/hdb6 swap swap defaults 0 0


For LinDVD, under properties, the DVD Drive is listed as /mnt/cdrom. The m in cdrom is partially obstructed so I can't confirm whether it says cdrom or cdrom1 or cdrom2 etc. There is no option to change it.


If I assume that it says /mnt/cdrom I suppose I could change my fstab for /dev/hdc to point to /mnt/cdrom and /dev/hdd to point to /mnt/cdrom2 but this would affect any other associations I've already setup for those devices.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...