Jump to content

To NOAPIC or not to NOAPIC

Guest arise

Recommended Posts

That is the question...


Let's get this straight...are u trying to tell me that MD 9.0 has buggy USB support OUT-OF-THE-BOX ???????


I had to use NOAPIC otherwise my NICs wouldn't work properly, and the system would take aeons to boot...


What's the truth about it?

Link to comment
Share on other sites

Guest javahacker

Someone correct me if I'm saying this wrongly, but there is a kernel related problem with some motherboards that have an APIC style interrupt controller chip. The chipset on these motherboards, in combination with the BIOS, doesn't work with the kernel code properly. The installation code tries to detect this problem, and inserts NOAPIC for those motherboards that Mandrake knows won't work (because someone told them about problems during the beta testing).


My personal system has had no problems with any of it's hardware using 9.0. I suspect that is the experience of most users. This is a very solid release, at least as far as everyone I know who installed it.

Link to comment
Share on other sites

  • 1 month later...

Got this NICproblem too, with my ECS A7S6A mobo. Tried the NOAPIC in lilo.conf. It didn´t work, so i tried to disable APIC in BIOS. Tataa, it worked. I´m running dualboot with WinXP, and with Win i have to enable APIC. This is kind of anoying, going into BIOS everytime i switch OS. Is there a way around this?

Link to comment
Share on other sites

  • 2 weeks later...
Guest sleeping_sloth

Hey all....

I posted a long problem on here not long ago (best part of a week now)

which eventually I found was an APIC problem. I messed with MDK for days and days, and even after I used the NOAPIC command I found that I had loads of problems with packages not being installed correctly. In my frustration I downloaded RH8.0, wrote and installed without any problems.


My board is a dualie - an Asus A7M266-D, and adding NOAPIC into the grub loader config works - but now the initialisation is failing on the network card configuration - is this going to be related to the noapic command?


In reply to the post above: where did you insert the noapic command in the loader? I added it directly after the kernel command, and not at the end of that line, where I was told to put it (where it didn't seem to work)


Sloth out

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...