Jump to content
Guest mandar

Problem getting the GUI screen for Mandrake 10.0

Recommended Posts

Guest mandar

hi,

 

I am new to Linux and wanted to try it on my new laptop(Dell inspiron 9300). I did the installation using Mandrake 10.0. There were 2 things which it was not able to configure, the Graphics card and the sound Card. The given choice while installing did not work. Any idea on how to get these drivers?

After installing i rebooted the m/c and it took be to the Linux Command prompt. Being a newbie i had no idea on what to do next. Any idea on how to get into the graphics mode? I think the problem could be related to the graphics card driver not being installed...

 

your help would be appreciated..

 

mandar

Share this post


Link to post
Share on other sites

login and type "startx" at the command prompt. Post back what you get.

Share this post


Link to post
Share on other sites
Guest mandar
login and type "startx" at the command prompt. Post back what you get.

Typed in "startx", gave one page full of text.. but the error message read like this...

(EE) No device detected

FATAL Server Error: No Screen found.

Share this post


Link to post
Share on other sites

Maybe some more information would help: graphics card brand and model, how it is plugged (PCI, AGP, integrated to MB), mainboard brand and model...

 

Yves.

Share this post


Link to post
Share on other sites
Guest mandar
Maybe some more information would help: graphics card brand and model, how it is plugged (PCI, AGP, integrated to MB), mainboard brand and model...

 

Yves.

 

It is a Dell Inspiron 9300 notebook. The graphics card is 128 MB ATI Mobility Raedon X 300. I am not sure how it is plugged to the MB, but will try finding it out. Any help in the meantime would be useful..

 

mandar

Share this post


Link to post
Share on other sites

Your x server is misconfigured. Log in, su to root, and type XFConfig. You should get a configuration program.

Share this post


Link to post
Share on other sites
Guest mandar
Your x server is misconfigured. Log in, su to root, and type XFConfig. You should get a configuration program.

below is the sequence of commands i executed after i logged in as root.

SU root

xfconfig

it gave me a "No command found" message..

Share this post


Link to post
Share on other sites

Sorry. After switching to root, type "XFDrake". That should get you there.

Share this post


Link to post
Share on other sites

First you need to know what the horizontal and vertical sync ranges are for your monitor. Then, run xfconfig. When you get to the part where it asks vertical sync the bottom choice is to enter your own settings. Choose that and enter the settings for your monitor. The same for horizontal sync. The bottom choice is to enter your own horizontal settings. Again, choose that and enter the horizontal settings for your monitor. Complete the xfconfig program. I'm sure that this will get you going. Also, take a close look at the default mouse settings in xfconfig. I believe that that particular setting has screwed me a few times. The error message you get when you type 'startx', if the server dowsn't start, should tell you if it's the mouse or the video that's holding you back. Examine the output closely. Even though it's barely comprehensible the answer to your problem is in there. Hope this helps.

 

Glennzo

Share this post


Link to post
Share on other sites

When you use startx and get that error message page, just slow down, calm yourself and take the time to read through the complete message slowly and deliberately and you should not be surprised to find that the cause is explained in 1 to 2 lines around about the middle. I used to be overwhelmed by all the text and one day, I did what I suggest to you, and was astounded how it worked. Because I had gained just a teeny bit of experience with VIM, I went to the file the messages described and found the incorrect text line exactly where the message said it would be and found it was one word with a letter missing. Guessing what the correct spelling for the word should be, I typed the correction ,saved it and rebooted. Next thing I know I am moving into my account normally.

 

If I had typed in kde instead , I would not have known what the problem was other than the fact that I couldn't gui into my account.

 

If you do not want to try that yet then make a note of most of the text and post it here. I am certain someone of us will be able to help you solve its meaning.

 

Cheers. John.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...