Jump to content

CVSCedega sound issues on all games


Recommended Posts

Hi Everyone,


Hopefully someone can help me. I can not run any games using CVSCedega. I have installed them using cedega and loki installers and both complete fine. The problem occurs when I try to run them. Like MaxPayne2 for example - it starts fine and I get the Video setting screen prompt I click play and imediately get this error:


Exception in engineInit:X_SharedDB: There was nothing inside "Sounds", database incomplete


So I thought maybe that game was just bad so I installed Call of Duty using loki installer and tried to run it, here is what I got:


err:module:BUILTIN_LoadModule loaded .so but dll winealsa.drv still not found


So I think it is safe to say that I have a sound issue. But I am not sure what to do to fix it. I am running ALSA and it starts at startup and I have Sound in X and in native games like Doom3. So I am not sure what is happening here - Here is my cvscedega config file as it refers to sound:



;; This option indicates if Cedega should accelerate

;; interprocess communication (AIC) between the client

;; and server.

"SHMWineserver" = "Y"



"Drivers" = "winealsa.drv"

;"Drivers" = "wineoss.drv"

"WaveMapper" = "msacm.drv"

"MidiMapper" = "midimap.drv"



"UseMMap" = "N"

"FullDuplex" = "N"

;; Specify a mapping for what digital audio devices to use

;"dsp0" = "/dev/dsp0"

;"mixer0" = "/dev/mixer0"



;; This option allows you to configure Cedega to write directly

;; to memory on the sound card rather than having to use the

;; slower route through the kernel.

"UseMMap" = "Y"

;; These options allow you to specify what ALSA sound devices

;; Cedega should use. Appropriate selection of these options

;; can allow you to select a secondary sound card or a plugin.

;"pcm0" = "hw"

;"ctl0" = "hw"


Does anyone know where I should start? Running Mandrake 10.1 with 2.6 kernel and GF4 Ti4200 vid card.


Any help would be appreciated, as you can tell I am kinda new at gaming in linux, but really would like to get it going so I can finally kick the winxp habit for good.


Thanks in Advance,


TheSonic1 :unsure:

Link to comment
Share on other sites

I tried with old version 4.2.1 RPM and 1.3.2 point2play and got the exact same error messages. So I do not think it is CVS issue


i tend to agree..

try to disableing arts {sound server} in kde and try playing a game.. arts tend to conflict with some audio programs... all try playing a game from gnome to see if the issue is with KDE.. but i think the problem might be arts

Link to comment
Share on other sites

Disabled the sound system option is the KDE Sound system config screen in 10.1 - same error - even restarted to see if the setting was still disabled and it was. Interestingly I did a search for winealsa.drv and I have no file by that name - do you know where it is supposed to be located?

Link to comment
Share on other sites

also: Just logged int ICEWM and ran from console as root - same error - I am sure it has something to do with winealsa.drv - as I looked at the startup script after trying to run both maxpayne2 and cod from the console as root as both refference that file - and I can not seen to find where that is supposed to be located

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...