Jump to content

kde problems


Recommended Posts

I am having some problems with kde lately, and I think opera may be the cause? When

online I use opera 7.54 as my browser/email. While browsing, at random points, kde will

crash at my screen will blackout, and my xserver and kde will restart. Could opera cause

kde to crash like this? I changed all the default fonts in opera to the helvetica-adobe font.

Could it be something else that is causing this? Is there a log file that wouls show why this

crashes? Tonight it went down 3 times, and its getting to be a real pain. Thanks for any




Link to comment
Share on other sites

Have yo noticed this happening with any other programs or at certain sites (like mayber some site you go to runs some script Opera doesn't like)


Also, and I know this is a long shot, I have had issues in the past, where a particular nvidia driver and a particular program simply didn't play nice. The example that comes to mind is the version of mozilla that came out with mandrake 9.2, and whatever version of the nvidia driver was newest when that came out. Once they gt updated, I had no more problems.


I don't have any explanation for that, and very few people have reported similar experiences, but you never know. So, you might want to try rolling back your nvidia driver to an older version, or updating it to a newer version if there is one.

Link to comment
Share on other sites

it could be the Helvetica-Adobe fonts causing the XFont Server to crash. try changing the Opera fonts to something different/more standard & see if the crashes continue. if not, problem solved. if they do continue with normal fonts, then i'm at a loss right. i use Opera 7.54 with no problems.



Link to comment
Share on other sites

Well, its happened again. This time i was adding songs to my playlist in amarok and it

went down. Also, I am using opera 7.51, and switched the fonts to the standard font

that mandrake usaes on the desktop. Awhile ago i read somewhere that installing font

from windows caused problems in kde, which I have installed. Has anyone else heard

this? I guess I'll have to uninstall them, but I don't think any of them are being used.

Oh, I am using the latest nvidia drivers. Thanks for the replies.



Link to comment
Share on other sites



it could be the Nvidia drivers causing the problem. when you say X crashes & KDE restarts, do you mean you have to relogin to KDE, or the screen just goes black for a few seconds & a mouse or keyboard movement brings it all back? if it's the latter, i had that problem with Nvidia drivers a while back. i added the NvAGP option to my xorg (or XFree, whichever the case may be) file & it fixed it. if you don't have this already, try adding the following to your xorg/xf86config-4 file(s) under the "device" section..........


Section "Device"

    Identifier "device1"

    VendorName "NVidia"

    BoardName "NVIDIA GeForce4 (generic)"

    Driver "nvidia"

    Option "DPMS"

    Option "NvAGP" "3"

    Option "NoLogo" "1"



the "3" option tells it to try kernel AGP first, then Nvidia AGP if that fails. other optins you could use are........


"0" (uses no agp support)

"1" (uses nvidia agpart only)

"2" (tries kernel agpart only)


if you do this, you don't need to kill X to make the edit. just edit the appropriate file with any text editor. you must reboot for the settings to take effect.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...