Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  

MP4 Videos from U-Tube [solved]

Recommended Posts

I have 4 video players installed in my Mageia-4 machine.

I find Xsine not worth the time because it takes just about for ever to set, it is just seems so complicated.

My old faithful, Totem is totally useless nowdays since it now seems to not play practically most of regular formats it used to play

up until about a year ago.


Svlc and Dragon will play the U-Tube sourced MP4's but with no sound. However they do play MP4's from other sources quite OK. They also play AVI, MOV and other formats quite OK.


Any ideas I can try or explanations, please.


Thanks in advance. John.

Edited by AussieJohn

Share this post

Link to post
Share on other sites

Hi John


Please check the mp4 file with mediainfo. It should be in your repos, it is also available here:


for Mageia 4:



Install it and check for audio like this:

greg@halfway:~/Videos/dlh-vids$ mediainfo novena.mp4
Complete name                            : novena.mp4
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42
File size                                : 13.7 MiB
Duration                                 : 2mn 24s
Overall bit rate mode                    : Variable
Overall bit rate                         : 797 Kbps
Encoded date                             : UTC 2014-04-02 05:46:13


ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : 40
Duration                                 : 2mn 24s
Bit rate mode                            : Variable
Bit rate                                 : 103 Kbps
Channel count                            : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Delay relative to video                  : 83ms
Stream size                              : 1.77 MiB (13%)
Encoded date                             : UTC 2014-04-02 05:46:13


Please post your audio section here.

Share this post

Link to post
Share on other sites

Thank you Greg.

I installed the Mediainfo tool as suggested.

I found that all the MP4s that worked OK all had Audio headings an data as were expected to have.

However all the MP4s that worked without sound had NO Audio heading and so no sound data shown. none, zero, zilch, nil.


Since all of these faulty downloads were via Firefox this would now seem to be a problem with Firefox somehow or the video Downloaders which are DownloadHelper

or Flash VideoDown Loader. I have checked their settings and can see nothing that would seem to be out of place.



Share this post

Link to post
Share on other sites

I just used firefox 29 with downloadhelper 4.9.22 to d/l an mp4 from youtube. It plays ok with vlc media player 2.0.8. I’m not sure why your audio is missing.


Maybe if you d/l the file in flv format and convert it to mp4 it will work?

Share this post

Link to post
Share on other sites

Thanks Greg for the idea. I haven't tried it and likely would work but that is going around the problem rather than

trying to determine what the cause of the problem is and then finding a solution, which is what I would prefer.

I am using Download Helper 4.9.17


Cheers. John.

Edited by AussieJohn

Share this post

Link to post
Share on other sites

A follow up.

I noted that your helper version was 22 and mine was 17.

I installed 22 and that was the answer. All of the videos that I had problems with I have now been able to re-download and they play properly.

I had not realised that there was an updated version available because I thought that I had set things up for auto notification of updated versions in apps for Firefox.

Clearly this wasn't coming through for VideoHelper.

So problem is now solved.


Thanks again greg.

Cheers. John.

Share this post

Link to post
Share on other sites

I’m glad you have it working.


It’s nice to see some new post here when I check in. :)

Share this post

Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this