Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
Kieth

skype video-get it working automatically [solved]

Recommended Posts

In console, I can start skype with the LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype command, and the video works fine. How can I get it to start with that command automatically when the computer starts? I've tinkered around with it, adding it to some files, but no luck.

 

Thanks,

Kieth

Edited by Kieth

Share this post


Link to post
Share on other sites

Easiest way is to make another script, something like this:

 

#!/bin/bash
#
# Loads skype with v4l1compat.so

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

 

save it as /usr/bin/myskype or whatever you want to call the script, then do:

 

chmod +x /usr/bin/myskype

 

and then make new shortcut/icon pointing to /usr/bin/myskype. If I find another method from the icons without the script, I'll let you know. I'm sure I did this once myself without the script, but can't remember how exactly.

Share this post


Link to post
Share on other sites

:D Thanks! Got it working. There is one oddity, though. No big deal really. When we turn on the computer, the skype window comes on. That's the skype I don't want. We close it out, then click on the icon I created on the desktop to start the skype we do want. Is there anyway to keep that first window from appearing? If not, it's really no big deal. I'm just happy that we can use the video! :thumbs:

 

Thanks again,

Kieth

Share this post


Link to post
Share on other sites

You probably have it starting automatically somewhere, so you'll need to find out where you put this or perhaps in Skype preferences there's something about starting automatically when you start your computer (unless I'm getting confused with Windows) :)

 

But probably you have it somewhere under KDE/Gnome for auto starting if there is no option within Skype itself.

Share this post


Link to post
Share on other sites

Thanks. I looked around before, but couldn't find anything. I'll look around again, though. Maybe this time will the the lucky time. :)

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×