Jump to content

Won't boot with default kernel settings


Recommended Posts

Getting around to tidying up my install on my Acer aspire one.


When booting using the default settings, I use verbose and it all goes well, then the mouse pointer shows (prior to the login screen) and it hangs.


I have not tried safe settings yet. If I use no acpi it boots fine it seems.


Other issues I have picked up:

Volume is a little low

Cant find a battery level monitor

Cant enable 3d graphics-I'm pretty sure that these rockets do 3d.


Other than that it works really well.


As usual, I'm not sure where to start with these issues. Any help most appreciated.



[moved from Hardware by spinynorman]

Link to comment
Share on other sites

Well I don't have much to offer.


The fact that you have turned off ACPI implies that battery level notifications will not work.


I would google Acer, aspire, and ACPI to see what other boot options might be more appropriate.


I just went through this with a Toshiba laptop. I had to use acpi_osi="Linux" to get the AC adapter to acknowledge insertion of the power cord.

Link to comment
Share on other sites

  • 2 weeks later...

Ok, had a break through.


At the login screen I tried to get to a cli interface rather than GUI by ctrl+alt+f1, and it took a few seconds then showed


Checking for new hardware


I see there is a new BIOS update for my machine. I guess this may have something to do with it.


EDIT: New Bios successfully installed, but same issue remains

Edited by xboxboy
Link to comment
Share on other sites

When booting, press ESC to get rid of the splash screen, and see if you've got the interactive option. Haven't checked this, and didn't want to reboot my system as I'm at work now :)


Along time a go there used to be the harddrake service, but it doesn't exist anymore. Else I'd have suggested disabling this.


Also, there is a failsafe option from your grub list of kernels, try this. Alternatively press "E" at the grub screen, and edit the kernel line for the kernel you are running, and at the end of the line add "single" without the quotes so that we can boot single mode.


One more thing, when you did get to the console window, could you do anything such as login as root or something? Maybe just X locked up, or is it the whole system?

Link to comment
Share on other sites

  • 3 weeks later...

As it boots, with the default kernel settings, if I press ESC to get the verbose screen I don't have the option to enter the interactive start up.


If I switch to a console screen as soon as it says checking for new hardware it locks up, so no I can not log in through the terminal.


I will try to login in single mode.

Link to comment
Share on other sites

  • 2 weeks later...

Ok, so if I press ESC to go to non-graphic login I have a failsafe option. This does not work, seems to stop at: starting udev?

I did add 'single' to the kernel line, still with the same result of stalling at: starting udev

Which is weird as if I boot normally it stops at: Checking for new hardware


I'm pretty sure this is a system halt and not an X issue.


My only thought is (and I could be completely wrong, as I do not know how linux installs itself) as I was running an old BIOS it didn't install all the drivers I need, hence it stalls when checking for new hardware?


It's strange as many people seem to Mandriva installed on AAO with no issues what so ever.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...