Jump to content

Establishing a CDMA modem connection using wvdial

Guest kedar

Recommended Posts

Hi all,

I am trying to use TATA Indicom CDMA USB modem on Mandriva Linux 2008

using wvdial.

I have edited wvdial.conf file as per company's suggestion and it looks as follows:

[Dialer Defaults]

Init1 = ATZ

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

stupid mode = 1

Modem Type = USB Modem

ISDN = 0


Phone = #777

Modem = /dev/ttyACM0

Username = internet

Password = internet

Baud = 460800


I know it works because I have used it on Open SUSE on same computer and have

got no problems.

On Mandriva, when I run wvdial and then disconnect using Ctrl+C, I get following



[root@localhost kedar]# wvdial

--> WvDial: Internet dialer version 1.56 (abuild@mandelbrot)

--> Cannot get information for serial port.

--> Initializing modem.

--> Sending: ATZ



--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0


--> Modem initialized.

--> Sending: ATDT#777

--> Waiting for carrier.



--> Carrier detected. Starting PPP immediately.

--> Starting pppd at Tue Aug 26 08:00:01 2008

--> Pid of pppd: 6954

--> Using interface ppp0

--> pppd: h[16][06][08]�[1e][06][08]

--> pppd: h[16][06][08]�[1e][06][08]

--> pppd: h[16][06][08]�[1e][06][08]

--> pppd: h[16][06][08]�[1e][06][08]

--> local IP address

--> pppd: h[16][06][08]�[1e][06][08]

--> remote IP address

--> pppd: h[16][06][08]�[1e][06][08]

--> primary DNS address

--> pppd: h[16][06][08]�[1e][06][08]

--> secondary DNS address

--> pppd: h[16][06][08]�[1e][06][08]

Caught signal 2: Attempting to exit gracefully...

--> Terminating on signal 15

--> pppd: h[16][06][08]�[1e][06][08]

--> Connect time 0.6 minutes.

--> pppd: h[16][06][08]�[1e][06][08]

--> pppd: h[16][06][08]�[1e][06][08]

--> Disconnecting at Tue Aug 26 08:00:40 2008


If I ping primary or secondary DNS, I get following output:


From icmp_seq=1 Destination Host Unreachable

--- ping statistics ---

0 packets transmitted, 0 received, +48575 errors


On one blog I found that wvdial requires a file /etc/resolve.conf with IP addresses of

primary and secondary DNS. I manually created the file but problem persisted. I have

also tried adding the two IP addresses in hosts file using Mandriva Linux Control

Centre, but no solution.


What is happening ? Because of this I am not able to connect to the internet.



Link to comment
Share on other sites

I have already tried KPPP. But it doesn't recognise my modem, although it is showing correctly in network centre.


I have installed open SuSE again. and after running wvdial from it, I have figured out that wvdial starts the ppp daemon (pppd) which then executes the ip-up script. In Mandriva, pppd starts correctly but not ip-up. So, I will take back up of ip-up and ip-down scripts in open SuSE, install Mandriva once again compare the scripts there and get back to you folks.



Link to comment
Share on other sites

I have already tried KPPP. But it doesn't recognise my modem, although it is showing correctly in network centre.

I suspect you just did not set it up right. See below how I set up kppp to work with my cellular PC Card modem. Of course your setup will be a little different. BTW, kppp is just a front end for ppp - same as wvdial.



Link to comment
Share on other sites

  • 2 weeks later...

I tried using kppp in Open SUSE and my internet connection was running fine there. So I set up the same settings in Mandriva 2008 and tried to connect. Once again I was not able to open any webpages.


Following are the messages I got in kppp:

Modem Ready

Logging on to Network


then in kppp's debug window:




ATQ0 V1 E1 SO=0 &C1 &D2 +FCLASS=0







Starting pppd


Then I get a pop-up from system tray

Network is up on interface ppp0


But I am unable to connect to internet.

Also I have found out from network monitoring programs that after the initial handshake not a single byte is transmitted or received.


What I think I missed was commenting out lines in link ifup-ppp script as provided in link by you (but there was no reason to do so in open SUSE) and I am using dynamic addresses (I am seeing correct primary and secondary DNS addresses in resolve.conf). But I will try these out too and let you know.


Mandriva 2008 on Acer Laptop


Edited by Kedar:

I followed the instructions provided by you line-by-line. Still no help

Here is the output:


root@localhost kedar]# ifconfig

eth0 Link encap:Ethernet HWaddr 00:16:D3:ED:C0:A7


RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



lo Link encap:Local Loopback

inet addr: Mask:

inet6 addr: ::1/128 Scope:Host


RX packets:128 errors:0 dropped:0 overruns:0 frame:0

TX packets:128 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:11248 (10.9 KiB) TX bytes:11248 (10.9 KiB)


ppp0 Link encap:Point-to-Point Protocol

inet addr: P-t-P: Mask:


RX packets:4 errors:0 dropped:0 overruns:0 frame:0

TX packets:5 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:3

RX bytes:40 (40.0 B) TX bytes:67 (67.0 B)


[root@localhost kedar]# route -n

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface UH 0 0 0 ppp0 U 0 0 0 ppp0


What am I missing ?

Edited by kedar
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...