Jump to content

Recommended Posts

Hi everyone,

 

I've done about as much Googling as I possibly can now I'm hoping for some of your expert advice.

 

I've got a Dell Latitude D620 laptop which has the Intel ProWireless 3945 wireless NIC. The reason I purchased this card for this laptop was the fact that Intel has traditionally supported their hardware under Linux. I am running Fedora 8 and had a 2.6.23 kernel. I had always used the ipw9345 Sourceforge page and gotten binaries and then had eventually used the Freshrpms dkms-ipw3945 and associated packages to make continually running the ipw3945 binaries simplistic. However, when I updated my software I got a 2.6.24 kernel and the autoinstaller didn't work. I'm forced to use the http://intellinuxwireless.org/ project's iwl3945 (iwlwifi) software. Until now I'm unable to get this working. I can OCCASIONALLY scan and find networks.

 

I removed all the ipw3945 stuff and made sure I had all the iwl3945 (firmware, etc.) installed. I added the following lines to my /etc/modprobe.conf

 

alias eth1 tg3

options eth1 disable_hw_scan=1

 

and removed all the blacklist entries for iwl3945. The relevant entry from lspci is

 

0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

 

and

 

from dmesg is

 

iwl3945: Intel® PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds

iwl3945: Copyright© 2003-2008 Intel Corporation

iwl3945: Detected Intel Wireless WiFi Link 3945ABG

iwl3945: Tunable channels: 11 802.11bg, 13 802.11a channels

 

My /etc/sysconfig/network-scripts/ifcfg-eth1 is

 

# Intel Corporation PRO/Wireless 3945ABG Network Connection

DEVICE=eth1

ONBOOT=yes

BOOTPROTO=dhcp

HWADDR=00:1b:77:23:52:85

TYPE=Ethernet

USERCTL=yes

PEERDNS=yes

IPV6INIT=no

NM_CONTROLLED=yes

 

I have nothing for WPA keys or anything like that. Is anyone else having any troubles with this change?

 

Jon

 

 

[moved from Hardware by spinynorman]

Share this post


Link to post
Share on other sites
when I updated my software I got a 2.6.24 kernel and the autoinstaller didn't work. I'm forced to use the http://intellinuxwireless.org/ project's iwl3945 (iwlwifi) software.

Here's a quote from intellinuxwireless.org

Using kernels 2.6.24 and up

 

These kernels have the iwlwifi driver included and the released drivers (available from this site under download page) do not work with these kernels. If you want to run the latest (or very close to it) development code with your kernel then you should use the compat-wireless project that retrieves the latest driver development code from the upstream repository. We do push our changes to this repository very frequently.

So if your native kernel module doesn't work for you (did you try it first), then go to linuxwireless.org, and d/l the latest daily tarball (that reflects the latest commits from linux/kernel/git/rchatre/iwlwifi-2.6.git), then follow the instructions listed at linuxwireless.org.

 

Please note this comment from linuxwireless.org:

Do I need this on Fedora?

 

John Linville actually builds Fedora kernels whenever he makes any updates to wireless-testing.git and these kernels are based on wireless-testing.git so you should just have to upgrade your kernel. What you get from these kernels will be exactly what you will get out of this package. Therefore you really only need compat-wireless-2.6 package on Fedora if you are using a really old kernel and you can't upgrade for some reason. Note that yum update is reasonably useful, although it can be weeks behind. If you want to be sure to get the latest Fedora kernels which have wireless-testing.git code in you can get them here: http://koji.fedoraproject.org/koji/userinfo?userID=388

 

Good luck, Jon :)

Share this post


Link to post
Share on other sites

Hi Greg,

 

I did try those out. Thanks for comments. I guess I had taken this to say I shouldn't need these updated drivers. But I guess that an updated driver SHOULD always work better. I'll definitely give them a try.

 

If it comes to it, I'll upgrade the kernel.

 

JME

Share this post


Link to post
Share on other sites

Hi Folks,

 

So after building the compat-wireless drivers, I see the NIC, the NIC sees my router. However, when I issue

 

/sbin/ifup eth1

 

I get the response

 

Error for wireless request "Set Encode" (8B2A) :

SET failed on device eth1 ; No such file or directory.

 

Thi s is what I got using the stock kernel drivers. I've got firmware and drivers installed. Any suggestions?

Share this post


Link to post
Share on other sites

You probably need to blacklist the kernel drivers and go with the firmware by itself. You can try the command from Konsole su ndiswrapper -ma . If that doesn't work, you probably need to manually edit /etc/modprobe.conf and add the line: blacklist ipw3945 or else blacklist iwl3945 .

 

I am still on 2007.1, and all I had to do for my Intel 2200bg card was copy the firmware files *ipw2200* to /lib/firmware. After a reboot I configured the card using the Network Configuration wizard.

 

In 2008.0, with a Netgear WG511v2 I had to add the line: blacklist mrv8k to /etc/modprobe.conf, then use ndiswrapper to install the firmware WG511v2.inf (with WG511v2XP.sys available at the same location as WG511v2.inf).

Share this post


Link to post
Share on other sites

I'll check to make sure I've got firmware going on. It should be there by default.

 

I thought about using ndiswrapper. It just seems crazy to use a level of software abstraction for hardware when there are drivers which are supposed to work.

 

Thanks for all your help everyone,

 

JME

Share this post


Link to post
Share on other sites

I have the iwlwifi-3945.ucode drivers in my /lib/firmware directory and even attempted to update these to suffer the same level of success i'm currently enjoying. :lol2:

 

Jon

Share this post


Link to post
Share on other sites

Fedora just released to yum a new kernel. I'm going to try to all of these things. THEN I'll get that kernel and give it a go. I can ALWAYS go back. You gotta love the Linux.

Share this post


Link to post
Share on other sites
alias eth1 tg3

options eth1 disable_hw_scan=1

That's aliasing your ethernet card to eth1, not your wireless.

 

Further, you need more information than what you put in /etc/sysconfig/network-scripts/ifcfg-eth1 to get a network connection.

 

Compare wireless and wired....

Wired, 1) you plug it in 2) get an IP.

Wireless, 1) Associate with a wireless access point, 2) get an IP.

 

For both, you can't do 2 until you do 1. And like ethernet where you must plug in the cable, wireless needs some input before it can do #1, usually the network name, and a key if you have security.

 

Given that you're on fedora, you don't need the above ifcfg-eth1 file. Just have the driver loaded and use Fedora's networkmanager implementation. Networkmanager is patchy at best, but you're going to have a hard time with anything else on Fedora.

 

Good luck

 

James

Share this post


Link to post
Share on other sites

Hi Iphitus,

 

You're right. I caught that and just didn't correct it on here, but in my modprobe.conf. I now have

 

alias eth1 iwl3945.

 

My wired NIC is eth0. Under ipw3945 the wireless NIC was eth1 and I would really like to keep it that way for naming conventions.

 

Using

 

/sbin/iwconfig eth1 essid myessidname

 

By associating with the router, do you mean changing essid under iwconfig? If so, I can do that. I have no passkeys or encryption.

 

I'll look more into networkmanager.

 

Thanks,

 

Jon

Share this post


Link to post
Share on other sites

Hi Everyone,

 

So...I took iphitus' advice and looked some more at networkmanager. I noticed that there were tools in place for it in KDE (I'm a KDE user). So I gave the

 

sudo yum install knetworkmanager

 

and i can connect flawlessly via wireless networking. So, I'm totally curious why NetworkManager can do this, but I couldn't from command line. Are there CLI tools for networkmanager?

 

JME

Share this post


Link to post
Share on other sites

One of the updates to network manager a month or so ago on F8 was to choose "let NM control the device" or something to that effect. Not in front of my laptop at the moment.

 

system-config-network

 

Will show you what I'm talking about.

Share this post


Link to post
Share on other sites
Hi Everyone,

 

So...I took iphitus' advice and looked some more at networkmanager. I noticed that there were tools in place for it in KDE (I'm a KDE user). So I gave the

 

sudo yum install knetworkmanager

 

and i can connect flawlessly via wireless networking. So, I'm totally curious why NetworkManager can do this, but I couldn't from command line. Are there CLI tools for networkmanager?

 

JME

 

probably just issuing the wrong commands. Or alternatively Fedora was overriding them. *shrug*

Share this post


Link to post
Share on other sites
Guest trash80

Sorry to dredge this up, but I was having the same issue and my google landed me here. What I found out by complete accident was while setting the wireless card up (in Mandriva 2008.1 Free), right after you choose Automatic IP ( my router does the DHCP ) and "Next", you have Get DNS servers from DHCP, which I have checked. But the cure came from clicking "Advanced" and for DHCP client, choosing "dhcpcd". My wireless card connected as soon as I finished the setup. I am not sure how "dhcpclient" was chosen ( I may have accidently done it previously ) but it seemed to be the trouble maker.

 

Now everything works fine with the iwl3945 driver.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...