Jump to content

mandrake will not start after grub

Guest chris

Recommended Posts

I've installed Mandrake 9 from a clean harddrive. Everything works great when I boot up. It displays either lilo or grub (I've tried both), and on choosing Linux, goes to the Linux Mandrake boot up screen, where the cursor flashes and nothing happens.


I've tried installing a lot of times, but nothing seems to get it past this stage. Also, when I select failsafe or linux-nonfb at the bootloader, I get this info:


Uniform Multi-Platform E-IDE driver revision: 7.00alpha2

ide: Assuming 33Mhz system bus speed for PIO modes; override with idebus=xx

PIIX4: IDE controller on PCI bus 00 dev 09

PIIX4: chipset revision 1

PIIX4: not 100% native mode: will irqs later

ide0: BM-DMA at 0x1020-0x1027, BIOS settings: hda:pio, hdb:pio

hda: IBM-DTCA-24090, ATA DISK drive

hdb: CD-ROM CDR_U200, ATAPI CD/DVD-ROM drive

ide0 at 0x1fo-0x1f7,0x3f6 on irq 14

hda: 8007552 sectors (4100 MB) w/468KiB Cache, CHS=993/128/63, UDMA(33)

Partition check:



It then gets stuck at this last point every time. Any ideas?





Link to comment
Share on other sites

Also, did you make a boot floppy during the install and, if so, can you boot from it ?

If you can boot from the floppy then lilo is not configured properly and it can be reconfigured in Mandrake Control Center>Boot>Bootconfig.


My guess is that's not your problem and you won't be able to boot from the floppy either. In that case, your partition table may be corrupted. I say that because the system halts right at the point where the partition table is read. What should follow is a listing of the partitions on your hard drive but the operating system can't read them from the partition table apparently.


A messed up partition table can occur if there were prior partitions on the hard drive that were not deleted properly or new ones created with a partitioning utility that was not functioning properly or used properly. If this is the case you can try using fdisk if you have a widows boot floppy and I beleive there is a similar linux utility which you may be able to access in rescue mode from a boot off CD1 as as mentioned above. You can also do yet another install, this time in expert mode were the existing partitions are graphically laid out during the partition/ format part of the install and that might give you some idea of what's going on with your partition table. The idea is to blow everything off the hard drive and make one large FAT partition if you use windows fdisk or one large linux and appropriate sized swap partition if you use linux utilities.

Link to comment
Share on other sites

I can get into rescue after F1-ing, and there's some response with chroot, i.e. it tells me to type 'chroot --help' for more info, but chroot /mnt will not work.


I'll try again and format the partitions.

Link to comment
Share on other sites

I notice you have an IBM hard drive. If you want to thoroughly check it out you can download a great utility from IBM at the following link:




With this utlity you can completely wipe the disk clean by zero filling every sector which will wipe out your partition table so you can start clean.

Link to comment
Share on other sites

Did you choose the partitioning or did you leave Mandrake to do it? I suggest you install in expert mode to give you control of the partitioning. At the very least you need a "/" root partition, a "/swap" partition (about 400-500 Mb) and a "/home" partition to save you from having to configure your options on every upgrade or install. See the Partitioning mini-How-to at htpp://www.tldp.org for size recommendations and the Partitioning section at http://www.mandrakeuser.org.



Link to comment
Share on other sites



Still having issues with Linux. I've


a) installed Mandrake on another computer, so the discs are fine.

B) tried installing both in lnx4win and separate partition form

c) tried using a linux boot disc

d) tried installing RedHat (!)

e) wiped the entire harddrive using the IBM program that writes zeros into all the memory blocks, and so should have sorted out the partition table.

f) tried using both fdisk and partition magic to sort out the partitions.


I still can't get the bloody thing to boot after install is finished. Any ideas? Please!



Link to comment
Share on other sites

Wow. You've been busy!

If your getting the same result with both Mandrake and Red Hat, it would appear to point to some basic hardware incompatability or possibly some problem with your bios set up. Your hard drive is certainly not being read from what I can see in your prior post and it can't be because of a corrupted partition table since you wiped the disk clean. If you can give a listing of your hardware set up, some one might be able to come up with some more ideas. Give the make and model of your computer along with: processor, motherboard chipset, IDE controller, hard drive model, BIOS, memory, CDROM, ect.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...