Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
Milo

Spring 2007 Creative Audigy soundcards - no sound

Recommended Posts

I have a Creative Soundblaster Audigy SE Value and it didn work under 1007.1 or Spring (But did under 2006!) If you have this problem then mute "audigy analog/digital output jack" in KMix ?witches tab - also see http://wiki.mandriva.com/en/Docs/Hardware#SB_Live. It took me a while to distill the correct fix for my sound card from all the post on the internet.

 

You might also try this (which worked for me in 2007.1 but not Spring):

Running and unmuting

 

Since we're Linux users, we don't want to reboot. So we'll start the alsasound script manually.

 

Code listing 3.2

 

# /etc/init.d/alsasound start

 

ALSA is running now. If everything is ok, you should be able to see the ALSA modules loaded when running lsmod. However, sound won't work yet, because the channels are still muted. We need amixer for this.

 

Code listing 3.3: Running amixer

 

# amixer

 

Warning: You shouldn't get this, but if you get an error about "amixer: Mixer attach default error: No such file or directory", you should manually modprobe snd-mixer-oss and snd-pcm-oss once. After that run amixer again.

 

Code listing 3.4: only if you get an error when running amixer

 

# modprobe snd-mixer-oss

# modprobe snd-pcm-oss

# amixer

 

If you got this far, now unmute Master and PCM channels. Some hardware even requires you to unmute the center channel or even the surround channel.

 

Code listing 3.5: Unmuting channels

 

# amixer set Master 100 unmute

# amixer set PCM 100 unmute

Only if the above doesn't succeed on its own:

# amixer set Center 100 unmute

# amixer set Surround 100 unmute

Test the sound:

# aplay $KDEDIR/share/sounds/pop.wav // (pop.wav is part of KDE)

 

We check to see if sound is working by using the aplay (alsa play) command. If you hear a pop, then sound is indeed working. Then, adjust the volume settings to your liking; the ncurses-based alsamixer is a great way to get them "just so".

 

You may want to emerge alsa-xmms as that will provide ALSA support for XMMS.

When you reboot your system, the alsasound init script will properly save and restore your volume settings.

 

Anyway, HTH.

 

Milo.

 

 

[moved from Hardware by spinynorman]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×