Jump to content
Sign in to follow this  
orca

windows 98 partitions unaccessible

Recommended Posts

Hi there

 

I have installed Mandrake 10.0 OE on my desktop PC. I have two hard disks: the first one is just for my Windows 98, with partitions C:, D:, E:, and F:; the second one has a partion G: for Windows 98 and all its rest is for my Linux, having two partitions with mount points /, and /home.

 

My problem is Mandrake, despite creating directories /windows/C up to /windows/G, does not show up anyting inside them. I guess this is related to the messages issued by the command dmesg listed below

 

...
Supermount version 2.0.4 for kernel 2.6
FAT: Unrecognized mount option code "437" or missing value
FAT: Unrecognized mount option code "437" or missing value
FAT: Unrecognized mount option code "437" or missing value
FAT: Unrecognized mount option code "437" or missing value
FAT: Unrecognized mount option code "437" or missing value
...

 

My /etc/fstab file reads:

 

...
/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode 0620 0 0
/dev/hdb7 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda1 /windows/C vfat umask=0,iocharset=iso8859-1,code=437,codepage=850,gid=users,users 0 0
/dev/hda5 /windows/D vfat umask=0,iocharset=iso8859-1,code=437,codepage=850,gid=users,users 0 0
/dev/hda6 /windows/E vfat umask=0,iocharset=iso8859-1,code=437,codepage=850,gid=users,users 0 0
/dev/hda7 /windows/F vfat umask=0,iocharset=iso8859-1,code=437,codepage=850,gid=users,users 0 0
/dev/hdb6 /windows/G vfat umask=0,iocharset=iso8859-1,code=437,codepage=850,gid=users,users 0 0
/dev/hdb5 swap swap defaults 0 0
...

 

Furthermore, during initialization the screen shows the following messages:

...

Mounting local file systems: mount: wrong fs type, bad option, bad superblock on /dev/hda1, or too many mounted file systems    [FAILED]

...

and similar sentences for other partitions

 

Could you help me to access the windows 98 partitions?

 

Regards!

Share this post


Link to post
Share on other sites

Try editing out the "code=437" line in fstab and see if that makes a difference. What is that option for anyway?

Share this post


Link to post
Share on other sites

Hi,

 

I checked, in fact, that, for instance, under my laptop, which dual boots for Windows XP and Linux Mandrake 10, there is no option 'code' on the fstab file. ..

 

However, I did not create or edit the fstab file at all, so I wonder what the result might be of deleting this option on the /windows partiitons: I do not know what 'code=437' menas or 'codepage=850', for that matter. I checked the man pages both for fstab and mount and they only referred to 'codepage' option, not to the 'code' one at all.

 

So again, don't you think it might be risky to delete that particular piece of coe? I do not want to risk losing any data on my windows partitions...

 

Thanks again!

Share this post


Link to post
Share on other sites

you won't lose any data. if the option is invalid, the partition won't be mounted, and if it's not mounted linux won't modify it.

 

if it doesn't work you can always put the code back in.

Share this post


Link to post
Share on other sites

Hi there,

 

Deleting the expression 'code=437' from my fstab /windows/C up to /windows/G lines (corresponding to my windows partitions) DID work; thank you very much.

 

Now I would like to know two things:

 

1) why the hell did this expression crept into my fstab file? which procedure 'incorrectly' made it appear there and what does it mean, if anything at all?

 

2) how do I make icons relative to these several partitions appear on my desktop area, like it happens for my floppy drive?

 

Cheers!

Share this post


Link to post
Share on other sites

General Definition:

 

/dev/hd<x><y> -- the actual "device" containing the dos partition

"x" and "y" are a letter and digit respectively

 

/windows/<x> -- the target "mount point" -- this is where you

(the end user) will "see" this partition under

linux's "all encompassing file system" [similar to

current windows's notion of "my computer", which

encompasses all the drives: hard, floppy or otherwise]

 

vfat -- the partition type [no need to joke about windows being

"bloated" when they themselves call their file system

"FAT" :) ]

 

users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

-- this is "the magic line" that you are interested in.

further breakdown:

 

"users" -- means ANYONE can mount & umount the partition

 

"gid=users" -- means the "group" membership should be

"users", not "root"; this by itself should allow you

to see the contents [and possibly write to the drive]

 

"umask=0002" -- this helps ensure you have the ability

to read/write the drive, no matter who you are

[unless for some strange reason you are not a "user"]

 

"iocharset=iso8859-1" and "code=437" -- this has to do

with how any "text" data is interpreted; may not be

needed if you are in the U.S.A. (your system will

already be using this charset and codepage)

 

0 -- [first zero] should this partition be backed up by dump?

unless you actually use "dump", you probably don't need

to worry about this field

 

0 -- [second zero] fsck on which "pass"? [zero means no

check is done at all] This is equivalent to the DOS

"scandisk on boot" setting for windows

 

 

Mandrake is a French Distro. That may be the reason for the code=437.

 

Google found answer:

http://www.google.com/search?q=code%3D437+...=utf-8&oe=utf-8

http://www.netsys.com/suse-linux-e/2003/01/msg00156.html

Share this post


Link to post
Share on other sites

Hi there,

 

I have been able to mount, read and write all my Windows 98 partitions on boot, after deleting the 'code=437' piece from my fstab lines, indeed, as told before. Now, I checked the links ac-dispathcer found and cannot really decide whether this option is NONEXISTENT or not; in several home pages, it is explicitly mentioned, despite, in fact, not being mentioned in the man pages for fstab and mount...

 

Now, I insist, I would like automagically to have the hard disk ICONS appear on my desktop area, as it does for my floppy disk. Is that possible?

 

Thank you

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...