Jump to content

Mandrake 10.0 won't configure eth0


Recommended Posts

Hello, All:


I'm installing Mandrake 10.0 on an Intel i440GX server board and Mandrake won't configure the on-board ethernet interface (the Intel 82559 Fast Ethernet LAN chipset).

  • The device registers in /proc/pci, (Bus 0, Device 14, IRQ 21)
  • Mandrake Control Center 10...
    • Connection Manager allows me to set 'start at boot' and 'DHCP' (though the settings seem to be go back to their original values after a reboot), and
    • Hardware Manager correctly shows the device and recognizes that it needs the eepro100 kernel module.

    [*]/sbin/ifconfig shows the MAC address.

...but the interface won't start.


Any ideas?


Eric P.

Sunnyvale, CA

Edited by epretorious
Link to comment
Share on other sites


what does

ifup eth0

says ?

/sbin/ifup: configuration for eth0 not found.


  • There isn't a /etc/sysconfig/network-scripts/ifcfg-eth0 file
    The /etc/sysconfic/network file only contains 'NETWORKING=yes'


Edited by epretorious
Link to comment
Share on other sites

FWIW: I've been looking around quite a bit and found a posting about a problem similar to mine (i.e., Mandrake wouldn't configure the wireless interface or the on-board interface). In his reply, Pzatch suggested turning off the on-board interface so I tried something along those lines: I removed the D-Link DWL-520 wireless adapter but it didn't make any difference: MCC still updates /etc/sysconfig/network-scripts/ifcfg- (instead of /etc/sysconfig/network-scripts/ifcfg-eth0). :angry:

Link to comment
Share on other sites

Try creating your own ifcfg-eth0 by using this:




Then as root run:


# ifup eth0

I had hoped to not resort to manual configuration but did anyway and the on-board ethernet works now.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...