Jump to content

FSCK not run after unclean shutdown ??


Recommended Posts

This is on 8.2 upgraded to 9.0


I tried posting this on MandrakeExpert, but it didn't seem to accept the form posting.



FSCK not run after unclean shutdown.


All my disk partitions are ext2 or swap.


After an unclean shutdown:

- How is it that the boot scripts ASK if I want to run fsck ? Shouldn't it just do it, without asking ?

- If I do hit "Y" in time, it seems that fsck isn't necessarily being run - sometimes boot continues much too quick to be consistent with running fsck, and there's no fsck output on the console. What's going on ?


Since I don't trust the boot scripts, I run e2fsck from the boot cd in rescue mode after an unclean shutdown.


You might ask what is/are the cause of the "unclean" shutdowns, but I'll ask about that separately.



Link to comment
Share on other sites

You might want to consider switching over to a reiserfs journaled file system. They maintain a journal of disk changes and in the event of a unclean shutdown, the volume is quickly brought up to date. Unfortunately it is not a simple matter of converting your file system. You probably would need to reinstall or make a new partition and copy data over.

Link to comment
Share on other sites

You might want to consider switching over to a reiserfs journaled file system.


Errm. Thankyou. Well, yes I could consider that, and I could consider a lot of other things.

I might look at ext3.


I can also hack the scripts so that fsck gets run on an ext2 filesystem that wasn't shut down properly.


But if I don't have any idea what the rationale is for not running fsck, that would be a hack and not a fix.


On the face of it, failing to run fsck on ext2 seems a quite demented decision. But I guess I'm missing something. Can anybody tell me what ?



Link to comment
Share on other sites

Guest jglen490

It would seem to be strange, but why not just run it manually. Not trusting installed scripts doesn't seem to hold too much water. You may as well decide not to run anything at all :? .


As to why it doesn't run fsck after an abnormal shutdown, that would depend on what happened during the session that was abnormally terminated -- if nothing happened, then nothing needs to be fixed, except for the fact that the session terminated abnormally.


So in the absence of more info, manually run fsck the next time this happens. In the meantime, I would strongly suggest you convert to a journaled filesystem. The ext3 system is good enough in most cases, but if you need something else, then there are several other journaling filesystems available for Linux and for your system.


Conversion to ext3 is a very simple entry. But it's your choice.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...