Jump to content

Pulseaudio and/or Alsa Issues [solved]


Recommended Posts

I have been having this sound problem for quite a while, and was hoping I can get some assistance with it....


A generic description of my problem is best given by an example: Start an audio file with mplayer (via a terminal) works fine for 15 min then get static. Kill mplayer and restart the song, get static right a way. Try and kill pulseaudio with "pulseaudio --kill", no good... Try it again and follow up with "pulseaudio --start", still no good. Try one more time... Bingo sound back on.


I run into this several times a day.... Log messages look like the following:


Jan 19 21:50:06 localhost pulseaudio[8627]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!

Jan 19 21:50:06 localhost pulseaudio[8627]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.

Jan 19 21:50:06 localhost pulseaudio[8627]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.


Anyone have any suggestions?



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...