Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
CxOrg

Samsung NC20 with Mandriva 2010

Recommended Posts

If you are using the qtcurve themes in both KDE and GTK applications, then you must remove gtk-qt-engine. They don't play nice together.

I can't tell if qtcurve is better than oxygen for both KDE and gtk+ with gtk-qt-engine. Both have advantages, and disadvantages. I use qtcurve myself, because it's much more customizable.

Share this post


Link to post
Share on other sites

Yes in fact you are right. It makes no difference removing gtk-qt-engine. The system config GTK control panel remains together with the selection of qtcurve as the selected theme.

 

Using gtk-qt-engine's "use my KDE style in GTK applications" results in some unexpected half mapped styles and sometimes freezes of KDE so I do not actually use it.

Share this post


Link to post
Share on other sites

An update kernel from the MIB repositories to 2.26.36.4 seems to give a helpful boost to application speed.

 

I recommend adding the MIB repositories. These can be installed at http://http://urpmi.mandriva.ru/?language=en

 

No change to the BT module initialisation but the suspend/resume is perhaps a bit quicker.

 

The improvement may well be due to the improved threading and scheduling I read about being implemented in the standard kernel.

 

Having this improvement I would also recommend clearing the caches in Firefox as my Firefox startup had really slowed. After clearing the startup returned to less than 10 seconds and more comparable to Chrome's swift startup. I prefer Firefox still due to the many useful extensions I use. I am sure that the startup would be quicker without them.

Edited by CxOrg

Share this post


Link to post
Share on other sites

Wireless connections have always been a bit slow to negotiate and a bit embarrassing compared to Windows and OSX which are generally quick and easy. I tried using NDIS wrapper to the Atheros 5001 XP driver thinking the Linux driver was the cause, but that did not work well at all.

 

I noticed the problem occurs on DHCP negotiation so I tried another DHCP client and installed dhcpcd . Configuring a known wireless connection to use this DHCP daemon (in advanced right at the bottom!) and the connection was then swift as we know it should be. Fantastic!!

 

I'll have to find out how to make this the default DHCP client, possibly by removing the default dhclient.

 

It turns out that once dhcpcd is selected for the wireless interface it remains the choice so it is not necessary to remove the ISC DHCP client. In fact trying this it also removes network-monitor so I have kept it installed.

 

This may well be a solution for other Atheros wifi module users with other Linux distributions where DHCP negotiation seems to be the problem.

 

PS: After road testing for some days of using this both at home and on my work I have tried most combinations and even dhcpxd as the client daemon. I'm finding dhcpcd is the most reliable client ahead of dhcpxd and dhclient for wlan0 connections. Wired ethernet seems to work best with the default dhclient. It seems they can co-exist though changing between clients for a specific connection seems to be problematic requiring at least several connection attempts if not a re-boot. Anyway wireless connections seem to be more consistent with dhcpcd.

Edited by CxOrg

Share this post


Link to post
Share on other sites

Having done the above work on the DHCP and wlan the general performance is again a bit better. Improved network performance helps most applications get on with what they should be doing without waiting. Thunderbird and Firefox work much better. I also removed 2 of the 4 virtual desktops which may reduce memory use. 2 desktops is normally enough for me!

Edited by CxOrg

Share this post


Link to post
Share on other sites

It is a while since I added anything new here this is due to my upgrade to an EeePC 1215b with the wonderful AMD Fusion E-350 APU. A very efficient dual core and graphic processing unit. I'll post a new thread on this soon with the experience of upgrading to Mandriva 2011.

 

This issue affects both 2010.2 and 2011 when using kvpnc to manage openvpn connections. Openvpn is now 2.2.1 and introduces script security which is not handled by kvpnc. It is a simple command line parameter as in $ openvpn --script-security 3 myopenvpn.config.

 

There is no way to add additional command line parameters to kvpnc so we get error messages in the log display like:

 

WARNING: External program may not be called unless '--script-security 2' or higher is enabled. Use '--script-security 3 system' for backward compatibility with 2.1_rc8 and earlier

 

The solution until this is fixed in kvpnc is to create a shell script which calls openvpn and adds the parameter.

 

create and put this script openvpn1 in /usr/sbin and set the permissions ( sudo chmod 755 openvpn1 )

#!/bin/bash
openvpn --script-security 3 $@
exit 1

Then change in the daemons section of kvpnc configuration the file called for openvpn to /usr/sbin/openvpn1

 

This takes care of starting any connection but breaks starting any new connection as openvpn remains loaded as a process and we cannot start a new one. I am sure there is a way to do this through the script but here is the quick and dirty solution.

 

In the "after disconnect" section of your kvpnc profile add "killall openvpn" (no quotes). This will remove the remaining openvpn process and a new connection starts from scratch as if it were the 1st connection. A bit brutal but it works.

 

Lets hope for a fix from the kvpnc team!

Edited by CxOrg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×