Jump to content

Epson C88 Printer is not printing [solved]


Recommended Posts



Please be patient with me. I'm a point 'n click type. I can follow directions (like posting output from the terminal), just help me out by providing me with very specific commands to type. I am still very much a newbie to this.


I recently loaded Mandriva Power Pack 2010 onto a Sony Vaio laptop. Installation went OK.


I then went to the "Configure your Computer" for hardware and started the process of setting up a printer. My printer was plugged in to a USB port (I have three (3). One (1) is being used by a wireless mouse). The wireless mouse is working flawlessly. The printer configuration routine recognized that I had an Epson C88 printer and appeared to load all the files.


I pressed the "Print Test Page" and it is still at "Processing" in the Print Queue. The green power light is blinking on my printer, but nothing is being printed.


I have tried looking through the forum to see if this has been addressed. If it has, please provide me a link. Thank you for your time and feedback.



Link to comment
Share on other sites

It would appear as though the wrong driver has been chosen for your printer. This does happen as Linux tend to provide a generic driver because the manufacturers fail to support Linux. If you have the driver CD for the Windows installation there will be a driver file on it which you can use. Insert the cd/dvd whichever it is and search for a file with a


extension. If there is more than one, or more likely more than one version of windows chose XP, this may not be the right one but it usually is. When you have found the file make a note of where it is. Go into mcc and open the printer set-up dialog, and double click on the printer icon, then where it says make and model click the change button. When presented with a list of drivers select the radio button that says provide PPD file. Make your way to the file on the cd/dvd and use that driver. Click your way back to properties dialog and try another test print. Good Luck.

Link to comment
Share on other sites

According to your other thread about gnucash, you now have your software repos set up properly. So I would suggest that you install the task-printing-epson package from the repos, it will also install some dependencies including the proper gutenprint driver to be used with cups, and the appropriate PPD file for your printer.


You may also want to install the mtink package. It's a nice configuration tool for epson inkjets that has a status monitor.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...