Jump to content

Man. 2010: Wireless worked on install... now dead

Guest landshark

Recommended Posts

Guest landshark



I'm new here so please let me know if there's a better forum. I look forward to your feedback. Here goes:


I just installed Mandriva 2010 on a Dell e6500. I am very impressed with the distro and am glad to be back to Mandriva. (I was a Mandrake user "back in the day" but had to jump ship for work purposes.)


My wireless worked great, both on the Live Disk _amazing! -- and on the initial install. It was flawless. But suddenly it stopped working, although I had not tinkered with it.


Here are the symptoms and some details:


1. First, I know the Linksys access point is functioning. I tested it on another box.


2. For the configured wireless network, the connectivity is shown as almost nothing. I can't connect to it. Sometimes the connectivity is displayed as better -- three bars -- but once I select "connect" it drops to almost nothing.


3. I know from the past that the ndiswrapper drivers don't work well with this card. iwlagn + the iwlwifi firmware does the trick. Both were installed as part of the distro installation.


Output from lspcidrake -v:


iwlagn : Intel Corporation|Wireless WiFi Link 5100 [NETWORK_OTHER] (vendor:8086 device:4232 subv:8086 subd:1321)


Output from modinfo iwlagn:


version:        1.3.27kds
description:    Intel(R) Wireless WiFi Link AGN driver for Linux
firmware:       iwlwifi-4965-2.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-2.ucode
firmware:       iwlwifi-6050-3.ucode
firmware:       iwlwifi-6000-3.ucode



output from lsmod | grep iwlagn


iwlagn                160740  0
iwlcore               175976  1 iwlagn
mac80211              149236  2 iwlagn,iwlcore
cfg80211               89956  3 iwlagn,iwlcore,mac80211





lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:""
         Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
         Tx-Power=15 dBm
         Retry  long limit:7   RTS thr:off   Fragment thr:off
         Encryption key:off
         Power Management:off
         Link Quality:0  Signal level:0  Noise level:0
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.  (***I'm not familiar with this one.***)





eth0      Link encap:Ethernet  HWaddr 00:24:E8:AD:2E:73
         inet addr:  Bcast:  Mask:
         inet6 addr: fe80::224:e8ff:fead:2e73/64 Scope:Link
         RX packets:37829 errors:0 dropped:0 overruns:0 frame:0
         TX packets:8529 errors:0 dropped:0 overruns:0 carrier:0
         collisions:2 txqueuelen:100
         RX bytes:7520570 (7.1 MiB)  TX bytes:1495014 (1.4 MiB)

lo        Link encap:Local Loopback
         inet addr:  Mask:
         inet6 addr: ::1/128 Scope:Host
         UP LOOPBACK RUNNING  MTU:16436  Metric:1
         RX packets:28 errors:0 dropped:0 overruns:0 frame:0
         TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:1500 (1.4 KiB)  TX bytes:1500 (1.4 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:24:D6:09:91:8E
         UP BROADCAST MULTICAST  MTU:1500  Metric:1
         RX packets:122 errors:0 dropped:0 overruns:0 frame:0
         TX packets:49 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:10637 (10.3 KiB)  TX bytes:7487 (7.3 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-24-D6-09-91-8E-F1-85-00-00-00-00-00-00-00-00
         UP RUNNING  MTU:0  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



At this point I'm flailing. Thoughts? Thanks for any insight.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...