Jump to content
Sign in to follow this  
rldev

Can't Enable Desktop Effects

Recommended Posts

Mandriva 2010 64bit

ATI HD 3300

 

I have searched, but I have not come up with anything. It worked in Kubuntu Jaunty and Karmic.

 

 

[moved from Audio and Video by Greg2]

Share this post


Link to post
Share on other sites

What driver are you using for the ATI HD3300? Are you using a basic ATI or did you install the proprietary ATI driver? If not, perhaps this is the problem. Once this is installed and working, you should be able to enable the desktop effects in the usual way.

Share this post


Link to post
Share on other sites

I am using the driver Mandriva installed for it which is fglrx I believe. I tried installing ATI drivers on a the install prior to this and it knocked out xserver. Perhaps there is a how-to somewhere?

Share this post


Link to post
Share on other sites

Mandriva 2010 64bit

Please post 2010 problems in the Cooker forum section until the Official Mandriva 2010.0 is released. I've moved this to Cooker for you. :)

Share this post


Link to post
Share on other sites

OK. I followed directions here:

http://wiki.mandriva.com/en/Updating_proprietary_drivers_from_backports

 

When done and rebooted, xserver would not start.

The log shows: fglrx: No Matching Device Section for instance.

 

To get xserver to run, I had to comment out ATI references in /etc/X11/xorg.conf

 

#Section "Device"

# Identifier "device1"

# VendorName "ATI Technologies Inc"

# BoardName "ATI Radeon HD 2000 and later (radeon/fglrx)"

# Driver "fglrx"

# Option "DPMS"

#EndSection

Share this post


Link to post
Share on other sites

OK after this, I tried using the HD Radeon Driver. Drake said to ignore broken xorg.conf, wrote a new one. Reboot and bang 3d and effects work.

 

I compared the 2 xorg.confs and I really do not see a difference. I'm a bit perplexed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...