Jump to content
xboxboy

Installing new scanner [solved]

Recommended Posts

Hello all,

I decided to purchase a V300 Photo scanner after much looking around.

 

Time comes to install it and I'm stuck.

 

I already have a HP1315 all-in-one and it works perfectly.

 

I have plugged in the V300, and in MCC it is detected as an Epson scanner. Unfortunately it's not listed.

 

So I head over to get the 'official drivers'. Epson sponsored site...I assume

 

Proceed to the download page, put in appropriate details...I'm running 32 bit. I have downloaded what I believe I need. These being:

iscan-2.20.1-1.i386.rpm 486,814 bytes

esci-interpreter-gt-f720-0.0.1-2.i386.rpm 381,387 bytes

 

I could not install iscan due to the iscan-sane package being present, this is a known issue, so I have removed it as suggested.

 

When I try to install iscan i get:

# rpm -ivh iscan-2.20.1-1.i386.rpm

Preparing... ########################################### [100%]

file /usr/lib/sane/libsane-epkowa.la from install of iscan-2.20.1-1.i386 conflicts with file from package libsane1-devel-1.0.19-7mdv2009.0.i586

 

How should I proceed from here?

Share this post


Link to post
Share on other sites

I have to use the force option to get my Epson working so try

rpm -ivh --force iscan-2.20.1-1.i386.rpm

Ken

Share this post


Link to post
Share on other sites

You can --force the rpm to install, as suggested. To see what happens, run as root in a console

sane-find-scanner

I can also suggest Vuescan (www.hamrick.com), which is a wonderful commercial application, and apparently it supports V300 (as well as most digicam RAW image formats). You can test it as long as you like, but the output will be watermarked. The pricetag is rather steep, but if you want the scanner for serious usage then (IMHO) it's moÏe than justified.

Edited by scarecrow

Share this post


Link to post
Share on other sites

Thanks guys!

 

sane-find-scanner

 # sane-find-scanner will now attempt to detect your scanner. If the
 # result is different from what you expected, first make sure your
 # scanner is powered up and properly connected to your computer.

 # No SCSI scanners found. If you expected something different, make sure that
 # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x03f0 [hp], product=0x3f11 [psc 1310 series ]) at libusb:006:002
found USB scanner (vendor=0x04b8 [EPSON], product=0x0131 [EPSON Scanner]) at libusb:001:003
 # Your USB scanner was (probably) detected. It may or may not be supported by
 # SANE. Try scanimage -L and read the backend's manpage.

 

Ok so it's detected.

 

rpm -ivh --force iscan-2.20.1-1.i386.rpm
Preparing...                ########################################### [100%]
  1:iscan                  ########################################### [100%]
[root@localhost Desktop]#

I assume that means it was installed correctly?

 

rpm -ivh esci-interpreter-gt-f720-0.0.1-2.i386.rpm
Preparing...                ########################################### [100%]
  1:esci-interpreter-gt-f72########################################### [100%]
[root@localhost Desktop]#

 

And it appears I could install the interpreter correctly.

 

I loaded up x-sane, and had the option to choose either the espson or the HP all in one. But when I choose the epson v300 I am told access to resource is denied. Is this because I installed the two rpm's as root?

Share this post


Link to post
Share on other sites

New information.

 

I can access sane and the scanner when running as root, ie kdesu xsane.

 

So it's a permission/grouping issue. I'm not sure how to resolve it from here.

 

Any help most appreciated.

Share this post


Link to post
Share on other sites

Hi scarecrow.

 

This is as user, matthew

$ groups
matthew

 

This is as root

groups
root

Share this post


Link to post
Share on other sites

That's strange... the above command SHOULD list all groups users "matthew" and "root" belong, respectively. Instead, it returns only the primary group...

What about

cat /etc/group

as root? It should return a fairly long list.

Edited by scarecrow

Share this post


Link to post
Share on other sites

cat /etc/group
root:x:0:                               
bin:x:1:                                
daemon:x:2:messagebus,haldaemon         
sys:x:3:                                
adm:x:4:                                
tty:x:5:                                
disk:x:6:                               
lp:x:7:                                 
mem:x:8:                                
kmem:x:9:                               
wheel:x:10:                             
mail:x:12:                              
news:x:13:                              
uucp:x:14:                              
man:x:15:                               
floppy:x:19:                            
games:x:20:                             
tape:x:21:                              
cdrom:x:22:                             
utmp:x:24:                              
shadow:x:25:                            
chkpwd:x:26:                            
auth:x:27:                              
usb:x:43:                               
cdwriter:x:80:                          
audio:x:81:
video:x:82:
users:x:100:
nogroup:x:65534:
rpm:x:101:
xgrp:x:102:xfs
ntools:x:103:
ctools:x:104:
messagebus:x:105:
polkituser:x:106:
vcsa:x:69:
haldaemon:x:70:
avahi:x:71:
avahi-autoipd:x:72:
htdig:x:107:
mysql:x:74:
slocate:x:108:
matthew:x:500:
lpadmin:x:109:
xfs:x:75:

 

and iscan as user returns:

Could not return command to scanner.

Check the scanners status.

 

Thanks guys

Share this post


Link to post
Share on other sites

Iscan can be run as root. Not as user though.

 

In etc/group i believe there should be a scanner entry. Is this correct?

Share this post


Link to post
Share on other sites

Ok i got it working now. I had to find the device and who owned it.

 

as root

lsusb

 

I found the device was part of group 189.

I had to create a user group for the scanner:

 

groupadd -g 189 scanner

 

then add me to the group

 

gpasswd -a username scanner

 

Then I needed to change that group root owned the scanner.

 

chown root.scanner /dev/bus/usb/001/003

 

I did not figure this out myself, I had the help of newsgazer and blingme from the mandriva irc chat.

 

Many thanks to them!

Share this post


Link to post
Share on other sites

Adding your user to the scanner group is the normal way to do things, but still I'm surprised your other scanner was working as plain user without setting him the right group priviledges.

Share this post


Link to post
Share on other sites

My HP scanner is a all-in-one, not sure if that makes any difference

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...